PAT甲级1061 Dating (20分) 简单 PAT有两个测试点略坑

1061 Dating (20分)

Sherlock Holmes received a note with some strange strings: Let’s date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm. It took him only a minute to figure out that those strange strings are actually referring to the coded time Thursday 14:04 – since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter D, representing the 4th day in a week; the second common character is the 5th capital letter E, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is s at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.
Input Specification:

Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.
Output Specification:

For each test case, print the decoded time in one line, in the format DAY HH:MM, where DAY is a 3-character abbreviation for the days in a week – that is, MON for Monday, TUE for Tuesday, WED for Wednesday, THU for Thursday, FRI for Friday, SAT for Saturday, and SUN for Sunday. It is guaranteed that the result is unique for each case.
Sample Input:

3485djDkxh4hhGE
2984akDfkkkkggEdsb
s&hgsfdk
d&Hyscvnm

Sample Output:

THU 14:04

思路:感觉读懂题就会做,先从 第一行和第二行字符串找到一个相同的大写字母,这个字母表示星期几,再继续从第一行和第二行字符串 找到一个相同数字或者字母,表示小时。 之后在第三行和第四行找到相同字母的位置。

PAT有两个测试点感觉很迷,一个是考察 第一行和第二行字符串找到第一个一个相同的大写字母,并且字母在’A’ 到’G’之间 。一个是考察 第一行和第二行字符串找到第二个相同的数字或者字母,并且字母在’A’ ‘N’ 之间

#include <iostream>
#include <string>
using namespace std;
int isBigLetter(char ch)
{
    if(ch>='A'&&ch<='Z')
        return 1;
    else
        return 0;
}

int main()
{
    string str1,str2,str3,str4;
    cin>>str1>>str2>>str3>>str4;
    char a=-1,b=-1;
    int c;
    for(int i=0; i<str1.size()&&i<str2.size(); i++)
    {

        if(str1[i]==str2[i])
        {
            if(a==-1)
            {
                if(isBigLetter(str1[i])&&str1[i]<='G')
                    a=str1[i];
            }
            else if(b==-1)
            {
                if(isdigit(str1[i])||(isBigLetter(str1[i])&&str1[i]<='N'))
                    b=str1[i];
            }
            else
                break;
        }
    }
    for(int i=0; i<str3.size()&&i<str4.size(); i++)
    {
        if(str3[i]==str4[i]&&isalpha(str3[i]))
        {
            c=i;
            break;


        }
    }
    string strMap[]={"MON", "TUE", "WED", "THU", "FRI", "SAT", "SUN"};
    cout<<strMap[a-'A']<<' ';

    if(isdigit(b)){
        cout<<0<<b;
    }
    else{
        cout<<b-'A'+10;
    }
    cout<<':';


    if(c<=9){
        cout<<'0'<<c;
    }
    else{
        cout<<c;
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值