Noodles的博客

代码编程都是套路,学习编程就是学习套路

Gradle sync failed: Plugin is too old, please update to a more recent version

一、概述

在使用Android Studio过程中,有时候会遇到标题中的异常,主要原因是在项目中的gradle.properties中依赖包版本过低。


解决办法:最简单的方式就是查找最新版本的jar包,并且修改为最新版本,然后系统会自动下载。


二、步骤

1、关于最新jar包,可以查看如下地址:http://tools.android.com/tech-docs/new-build-system



2、最上面2.2.0-beta2即为最新的版本。这时候需要注意的是,如果你在第一个图片中手动去修改并点击右上角的“try again”,有可能会继续出现一个gradle版本过低的错误。


主要原因应该是就这个jar需要更高版本的gradle支持它。


3、你需要去【File】-【Project Structure】或者按Ctrl+alt+shift+s快捷键,打开项目结构,点击第二个Project,把第一项“Gradle Version”和第二项“Android Plugin Version”分别设置为下面的值。



4、重新编译,成功。




阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_32736689/article/details/52369651
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭