用SQLSever2008R2创建的数据库 怎么附加到 SQLSever2008

问题:


众所周知,SQLSever有向下兼容,不向上兼容的特点,所以就会遇到下面的问题:

当你用高版本的SQLSever创建的数据库,要附加到低版本的SQLSever里面会出现以下错误:

我用SQLSever2008R2做的数据库,现在我要附加到SQLSever2008里面,就出错了

解决办法

1. 找一台安装好   SQLSever2008R2 的电脑,把你的数据库文件附加进去

2. 在SQLSever2008R2里面右击  你的数据库——》任务——》生成脚本(生成脚本按照默认设置就好了)

3. 把生成的脚本用生成脚本SQLSever2008打开(双击即可)

把单引号里面的路径改成你电脑中存放数据库的路径,然后点击执行(或者点击分析)发现数据库加进来了



总结:数据库脚本文件并没有高低版本之分,也就是说,脚本是通用的,可以作为一个  “中介”,可以让数据库文件   在不同版本之的SQLSever之间附加  

展开阅读全文

没有更多推荐了,返回首页