hdu1237-简单计算器

Problem Description

读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。

Input

测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。

Output

对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。

Sample Input

1 + 2
4 + 2 * 5 - 7 / 11
0

Sample Output

3.00
13.36


#include<stdio.h>
#include<string.h>
#include<iostream>
#include<stack>
#include<ctype.h>
using namespace std;
char str[1000];
int len;
struct ss
{
    int num,k;
} s;
ss get_num(int n)
{
    ss ans;
    int i,sum=0;
    for(i=n; i<len&&isdigit(str[i]); i++)
        sum=sum*10+str[i]-'0';
    ans.k=i;
    ans.num=sum;
    return ans;
}
double f(double c,double b,int oper)
{
    if(oper==1)return c+b;
    if(oper==2)return c-b;
    if(oper==3)return c*b;
    return  c/b;
}
int main()
{
    int i,j,flag,b,ope;
    double a,c,d,ans;
    while(gets(str))
    {
        if(!strcmp(str,"0"))break;
        len=strlen(str);
        stack<double>num;
        stack<int>oper;
        i=0;
        flag=1;
        while(i<len)
        {
            if(flag)
            {
                s=get_num(i);
                a=s.num*1.0;
                num.push(a);
                i=s.k;
                flag=0;
            }
            else
            {
                if(str[i+1]=='+')b=1;
                else if(str[i+1]=='-')b=2;
                else if(str[i+1]=='*')b=3;
                else  b=4;
                while(!oper.empty())
                {
                    ope=oper.top();
                    if(b==1||b==2||(ope>2&&ope+b>=6))
                    {

                        c=num.top();
                        num.pop();
                        d=num.top();
                        num.pop();
                        oper.pop();
                        a=f(d,c,ope);
                        num.push(a);
                    }
                    else break;
                }
                oper.push(b);
                i+=3;
                flag=1;
            }
        }
        while(num.size()>1)
        {
            c=num.top();
            num.pop();
            d=num.top();
            num.pop();
            ope=oper.top();
            oper.pop();
            a=f(d,c,ope);
            num.push(a);
        }
        printf("%.2lf\n",num.top());
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值