laravel 安装时候遇到 Fatal error: require(): Failed opening required (autoload.php)--composer安装

标签: PHP laravel框架 composer安装方法 windows
8人阅读 评论(0) 收藏 举报
分类:

laravel 下载地址:GitHub地址:点击打开链接

系统要求

运行 Composer 需要 PHP 5.3.2+ 以上版本。一些敏感的 PHP 设置和编译标志也是必须的,但对于任何不兼容项安装程序都会抛出警告。

我们将从包的来源直接安装,而不是简单的下载 zip 文件,你需要 git 、 svn 或者 hg ,这取决于你载入的包所使用的版本管理系统。

Composer 是多平台的,我们努力使它在 Windows 、 Linux 以及 OSX 平台上运行的同样出色。


安装 - Windows

使用安装程序

这是将 Composer 安装在你机器上的最简单的方法。

下载并且运行 Composer-Setup.exe,它将安装最新版本的 Composer ,并设置好系统的环境变量,因此你可以在任何目录下直接使用 composer 命令。

手动安装

设置系统的环境变量 PATH 并运行安装命令下载 composer.phar 文件:

C:\Users\username>cd C:\bin
C:\bin>php -r "readfile('https://getcomposer.org/installer');" | php

注意: 如果收到 readfile 错误提示,请使用 http 链接或者在 php.ini 中开启 php_openssl.dll 。

composer.phar 同级目录下新建文件 composer.bat

C:\bin>echo @php "%~dp0composer.phar" %*>composer.bat

关闭当前的命令行窗口,打开新的命令行窗口进行测试:

C:\Users\username>composer -V
Composer version 27d8904


博客借鉴:Composer 是 PHP 的一个依赖管理工具。它允许你申明项目所依赖的代码库,它会在你的项目中为你安装他们。


一开始是laravel5.0 但是下载好后,发现报错:后就composer install但是报的同样的错误。

Warning: require(E:\wamp\www\laravel5\bootstrap/../vendor/autoload.php): failed to open stream: No suc
y in E:\wamp\www\laravel5\bootstrap\autoload.php on line 17


Call Stack:
    0.0003     231704   1. {main}() E:\wamp\www\laravel5\artisan:0
    0.0009     235368   2. require('E:\wamp\www\laravel5\bootstrap\autoload.php') E:\wamp\www\laravel5




Fatal error: require(): Failed opening required 'E:\wamp\www\laravel5\bootstrap/../vendor/autoload.php
;C:\php\pear') in E:\wamp\www\laravel5\bootstrap\autoload.php on line 17


Call Stack:
    0.0003     231704   1. {main}() E:\wamp\www\laravel5\artisan:0
    0.0009     235368   2. require('E:\wamp\www\laravel5\bootstrap\autoload.php') E:\wamp\www\laravel5


Script php artisan clear-compiled handling the pre-update-cmd event returned with error code 255

后来没办法,就用了laravel5.2 再composer install之后,就可以了。下面再遇到问题:请点击laravel下载与安装遇到问题解决

查看评论

Win10安装很简单

-
  • 1970年01月01日 08:00

关于composer下创建laravel项目出错的解决办法

Composer是一个依赖管理工具(PHP>5.0),用composer可以用来管理改项目所需要的依赖(”packages” 和 “libraries”),在laravel中会体现在vendor文件夹...
  • Tianyi_liang
  • Tianyi_liang
  • 2016-12-01 16:51:16
  • 2967

安装 Laravel 遇到问题?你需要更新 composer.json 文件

$ php composer.phar create-project --prefer-dist laravel/laravel blogInstalling laravel/laravel (v5....
  • yicixing7
  • yicixing7
  • 2017-02-13 16:30:46
  • 4047

Laravel 5 Failed opening required bootstrap/../vendor/autoload.php 报错

down voteJust run the following commands,composer update Orcomposer install原来网址 http://stackoverflow...
  • abcde158308
  • abcde158308
  • 2017-01-12 18:01:12
  • 2285

windows下,源码配置Laravel5.3

windows下,源码配置Laravel5.3 网上很多教程或文章,都是使用composer进行创建Laravel项目。但是composer使用的源是国外的,如果不翻墙,是无法完成创建过程。当然国...
  • haygon
  • haygon
  • 2017-01-07 00:34:57
  • 1154

Failed opening required 'bootstrap/../vendor/autoload.php'

从git版本库克隆下来Laravel项目之后,忘了composer install ,结果爆了如下错误~PHP Fatal error: require(): Failed opening requ...
  • zhezhebie
  • zhezhebie
  • 2017-10-27 14:24:54
  • 822

Laravel访问出错错误信息:`Warning: require(/vendor/autoload.php): failed to open stream: No such file or dire

错误信息:`Warning: require(/http/www.mywakavLee.cn/bootstrap/../vendor/autoload.php): failed to open str...
  • leedaning
  • leedaning
  • 2015-06-03 12:47:19
  • 12413

安装YII

吸收了其它php网站的搭建经验,没想到安装yii的时候还是状况频出 1.下载了个yii2 advance的版本,运行里面的init,报错说须启动openssl 在php.ini里面uncommen...
  • sui84
  • sui84
  • 2015-07-10 22:16:23
  • 1459

Linux laravel 报错 或者 只能加载首页 点击404

Warning: require(): open_basedir restriction in effect. File(/home/wwwroot/default/test_act/bootstra...
  • lovetina2017
  • lovetina2017
  • 2017-10-11 23:42:17
  • 178

lnmp一键安装包部署了laravel框架后报错:

报错信息: Warning: require(): open_basedir restriction in effect. File(/home/wwwroot/default/blog/boo...
  • l_forever
  • l_forever
  • 2017-09-18 15:36:23
  • 668
    个人资料
    持之以恒
    等级:
    访问量: 6万+
    积分: 1996
    排名: 2万+
    最新评论