POJ 2142 The Balance [不定方程和最小的正整数解]【数论】

39 篇文章 0 订阅
26 篇文章 0 订阅

题目链接:http://poj.org/problem?id=2142

——————————————–.

The Balance
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 5998 Accepted: 2610
Description

Ms. Iyo Kiffa-Australis has a balance and only two kinds of weights to measure a dose of medicine. For example, to measure 200mg of aspirin using 300mg weights and 700mg weights, she can put one 700mg weight on the side of the medicine and three 300mg weights on the opposite side (Figure 1). Although she could put four 300mg weights on the medicine side and two 700mg weights on the other (Figure 2), she would not choose this solution because it is less convenient to use more weights.
You are asked to help her by calculating how many weights are required.
这里写图片描述

Input

The input is a sequence of datasets. A dataset is a line containing three positive integers a, b, and d separated by a space. The following relations hold: a != b, a <= 10000, b <= 10000, and d <= 50000. You may assume that it is possible to measure d mg using a combination of a mg and b mg weights. In other words, you need not consider “no solution” cases.
The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.
Output

The output should be composed of lines, each corresponding to an input dataset (a, b, d). An output line should contain two nonnegative integers x and y separated by a space. They should satisfy the following three conditions.
You can measure dmg using x many amg weights and y many bmg weights.
The total number of weights (x + y) is the smallest among those pairs of nonnegative integers satisfying the previous condition.
The total mass of weights (ax + by) is the smallest among those pairs of nonnegative integers satisfying the previous two conditions.

No extra characters (e.g. extra spaces) should appear in the output.
Sample Input

700 300 200
500 200 300
500 200 500
275 110 330
275 110 385
648 375 4002
3 1 10000
0 0 0
Sample Output

1 3
1 1
1 0
0 3
1 1
49 74
3333 1
Source

————————–.
题目大意 :
就是有一个天平 现在你要称N质量的物体
你只有a,b两种质量的砝码若干
问你最少需要每种砝码多少个才能称出N质量的物体
(要求在个数相同的时候选取砝码质量和最少的组合)

解题思路:
这道题目其实很简单 打眼一瞅就知道是一个扩展欧几里得

但是对于怎么输出最小的解得组合 这点就不太容易了

其实呢也不难 稍加分析就能得到结果了
首先呢
运用扩展欧几里得能够求出x,y的任意一组解
这样的话 假如求x或y的最小正整数解释非常容易的
只要x=(x%a+a)%a y=(x%b+b)%b这样就行了
然后想 要求出|x|+|y|的最小值怎么办呢
其实无非是两种
一种是在x为最小正整数解的时候
另一种是在y为最小正整数解的时候
证明略(取数是稍微想一想就知道了)

知道这个就好了

最后把两种的结果一比较 就能得出符合题意的解了

附本题代码
——————.

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>
using namespace std;
typedef long long int LL ;
#define INF 0x3f3f3f3f
#define pb push_back
#define abs(a) (a)>0?(a):-(a)
#define lalal puts("*******");
/*************************************/
LL exgcd(LL a,LL b,LL &x,LL &y)
{
    if(!b)
    {
        x=1,y=0;
        return a;
    }
    else
    {
        LL r = exgcd(b,a%b,x,y);
        LL t = x;
        x = y;
        y = t-(a/b)*y;
        return r;
    }
}

int main()
{
    int a,b,d;
    while(~scanf("%d%d%d",&a,&b,&d)&&(a||b||d))
    {

        LL x,y,vx,vy;

        LL r = exgcd(a,b,x,y);  //本题让求最小解
        a/=r,b/=r,d/=r;

        exgcd(a,b,x,y);

        /**********①令y是最小正整数解**********/
        vy = y*d;
        vy = (vy % a + a) % a;
        vx = (d-b*vy) / a;
        vx = abs(vx);
        /**********②令x是最小正整数解**********/
        x *= d;
        x = (x % b + b) % b;
        y = (d-a*x) / b;         //同理
        y = abs(y);
        /**********③使得和最小**********/
        if(x+y<vx+vy)    vx=x,vy=y;


        printf("%I64d %I64d\n",abs(vx),abs(vy));
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值