HDU-4707 Sum

Input
2
Output
2

        
 
  
  
Hint
1. For N = 2, S(1) = S(2) = 1. 2. The input file consists of multiple test cases.
Sample Input
2
Sample Output
2

        
  
Hint
1.  For N = 2, S(1) = S(2) = 1.

2.  The input file consists of multiple test cases. 


嗯,利用隔板原理,可以转换题意为求2的n次方,因为n比较大,所以可以用费马小定理的降幂公式

那个函数是欧拉函数,表示不大于n的与n互素的个数。

#include <bits/stdc++.h>

using namespace std;
typedef long long LL;
const int MAXN = 1e5+7;
const LL mod = 1e9+7;
char num[MAXN];
LL quick_mod(LL a,LL b)
{
    LL sum = 1,base = a;
    while(b)
    {
        if(b&1)sum = sum*base%mod;
        base = base*base%mod;
        b >>= 1;
    }
    return sum;
}


int main()
{
    while(~scanf("%s",num))
    {
        LL b = 0;
        int l = strlen(num);
        LL phi = mod - 1;
        for(int i = 0; i < l; ++i)b = (b*10+num[i]-'0')%phi;
        b = (b-1+phi)%phi;
        printf("%I64d\n",quick_mod(2,b+phi));
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值