poj3692 Kindergarten

这是一个关于在幼儿园场景下,寻找最大团队的问题。给定一定数量的女孩、男孩和他们之间的认识关系,目标是找到最大团队,使得团队内每个成员都互相认识。问题可以通过二分图最大匹配来解决,最大团队人数等于总人数减去最大匹配数。
摘要由CSDN通过智能技术生成

Kindergarten
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7244 Accepted: 3568
Description

In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.

Input

The input consists of multiple test cases. Each test case starts with a line containing three integers
G, B (1 ≤ G, B ≤ 200) and M (0 ≤ M ≤ G × B), which is the number of girls, the number of boys and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.

The last test case is followed by a line containing three zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.

Sample Input

2 3 3
1 1
1 2
2 3
2 3 5
1 1
1 2
2 1
2 2
2 3
0 0 0
Sample Output

Case 1: 3
Case 2: 4

题意:
已知班级有G个女孩和B个男孩,所有女生之间都相互认识,所有
男生之间也相互认识,给出M对关系表示哪个女孩与哪个男孩认
识。现在要选择一些学生来组成一个团,使得里面所有人都认识,
求此团最大人数。
首先你要知道:
• 二分图最小顶点覆盖数 = 二分图最大匹配数
• DAG的最小路径覆盖数 = V - 二分图最大匹配数
• 二分图的最大独立集数 = V - 二分图最大匹配数
求最大团,可以求补图的最大独立集 = v-最大匹配。

#include <cstdio>
#include <cstring>

using namespace std;
const int MAXN = 400+5;
int g,b,m;
int n;
int tu[MAXN][MAXN];
int match[MAXN];
bool vis[MAXN];
bool dfs(int u)
{
    for(int v = 1; v <= b; ++v)
    {
        if(!vis[v]&&!tu[u][v])
        {
            vis[v] = 1;
            if(match[v] == -1 || dfs(match[v]))
            {
                match[v] = u;
                return 1;
            }
        }
    }
    return 0;
}

int main()
{
    int ca = 0;
    while(~scanf("%d%d%d",&g,&b,&m)&&g)
    {
        memset(tu,0,sizeof tu);
        int u,v;
        while(m--)
        {
            scanf("%d%d",&u,&v);
            tu[u][v] = 1;
        }
        int ans = g+b;
        memset(match,-1,sizeof match);
        for(int i = 1; i <= g; ++i)
        {
            memset(vis,0,sizeof vis);
            if(dfs(i))ans--;
        }
        printf("Case %d: %d\n",++ca,ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值