1056 Mice and Rice (25分)

1 题目

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N​P
​​ programmers. Then every N​G
​​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N​G
​​ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N​P and N​G(≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N​G mice at the end of the player’s list, then all the mice left will be put into the last group. The second line contains N​P distinct non-negative numbers W​i (i=0,⋯,N​P​​ −1) where each W​i is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,N​P −1 (assume that the programmers are numbered from 0 to NP −1). All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3
    
Sample Output:
5 5 5 2 5 5 5 3 1 3 5

2 解析

  • 题意:从序列中以小组为单位进行晋级(每组晋级一个),逐轮角逐,最终得到序列中每只老鼠的排名
  • 思路
    • 用结构体存储老鼠的体重和排名,用队列存储当轮比赛的老鼠序号
    • 把当轮的老鼠分组,开始比赛(直到队列中只剩下一只老鼠)
      • 进行组内比赛,每次从组中选出胜利者, 每名成员的排名=(目前的分组数+1),全部出队,胜利者重新进入队列
      • 所有组比完后,更新下一轮老鼠数为前一轮的分组数,并重新计算分组数
    • 全部比赛完后,把队列中队首的老鼠排名更新为1
    • 输出排名

3 参考代码

#include <cstdio>
#include <queue>

using std::queue;

#define MAXN 1010

struct mouse//存储老鼠体重以及排名
{
    int m_weight;
    int m_rank;
}mouse[MAXN];

int main(int argc, char const *argv[])
{
    int np, ng, order;//分别存储老鼠数目、组容量、初始序列
    queue<int> q;

    scanf("%d%d", &np, &ng);

    for (int i = 0; i != np; ++i)//读入老鼠质量
    {
        scanf("%d", &mouse[i].m_weight);
    }

    for (int i = 0; i != np; ++i)//读入初始序列
    {
        scanf("%d", &order);
        q.push(order);
    }

    int groupTotal, temp = np;//分别记录当轮组数、当论参赛鼠数
    while(q.size() != 1){
        if(temp % ng == 0){//计算当论分组数
            groupTotal = temp / ng;
        }
        else{
            groupTotal = temp / ng + 1;
        }

        for (int i = 0; i != groupTotal; ++i)//枚举每一组,选出质量最大老鼠
        {
            int weightNumMax = q.front();//存放该组数量最大的老鼠数量
            for (int j = 0; j != ng ; ++j)
            {
                if(i * ng + j >= temp) break;//当最后一组老鼠数量不足ng时,退出循环

                int front = q.front();
                if(mouse[front].m_weight > mouse[weightNumMax].m_weight){
                    weightNumMax = front;//选出质量最大的老鼠
                }
                mouse[front].m_rank = groupTotal + 1;//该轮老鼠排名+1,4组晋级4个,被淘汰的排名第5
                q.pop();//出队这只老鼠
            }
            q.push(weightNumMax);//胜利老鼠晋级
        }
        temp = groupTotal;//groupTotal只老鼠晋级,下一轮老鼠数为group
    }

    mouse[q.front()].m_rank = 1;//队列中只有一只老鼠时,令其晋级

    for (int i = 0; i != np; ++i)
    {
        printf("%d",mouse[i].m_rank);
        if(i < np - 1) printf(" ");
    }

    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

繁星蓝雨

如果觉得文章不错可以请喝咖啡

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值