Raising Modulo Numbers

 

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 12094 Accepted: 7288

Description

People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow: 

Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions AiBi from all players including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing higher numbers. 

You should write a program that calculates the result and is able to find out who won the game. 
 

Input

The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.

Output

For each assingnement there is the only one line of output. On this line, there is a number, the result of expression 

(A1^B1+A2^B2+ ... +AH^BH)mod M.

Sample Input

3
16
4
2 3
3 4
4 5
5 6
36123
1
2374859 3029382
17
1
3 18132

Sample Output

2
13195
13

参考代码:
#include<cstdio>
//(a+b)%c = ((a%c) + (b%c)) % c;
typedef long long LL;
LL binaryPow(LL a, LL b,LL m){
    if(b == 0) return 1;
    if(b & 1) return a * binaryPow(a, b - 1, m) % m;
    else{
        LL num = binaryPow(a, b / 2 , m);
        return num * num % m;
    }
}
//LL binaryPow(LL a, LL b, LL m){
//    LL ans = 1;
//    while(b > 0){
//        if(b & 1){
//            ans = ans * a % m;
//        }
//        a = a * a % m;
//        b >>= 1;
//    }
//    return  ans;
//}


int main(){
    int N, n;
    LL a, b, m;
    scanf("%d", &N);
    LL ans = 0;
    while(N){
        ans = 0LL;
        scanf("%lld%d", &m, &n);
        for (int j = 0; j < n; ++j) {
            scanf("%lld%lld", &a, &b);
            a = a % m;
            ans = (ans +binaryPow(a, b, m))%m;
        }
        printf("%lld\n", ans);
        N--;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

繁星蓝雨

如果觉得文章不错可以请喝咖啡

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值