gzgchzc的博客

gzgchzc的博客

ionic升级到3.0之后,在使用命令:ionic cordova build android或者ionic cordova emulate android会提示以下错误

gzgchzc博客最新更新地址:http://blog.gzvtc.cc/

(node:4308) UnhandledPromiseRejectionWarning: Unhandled promise rejection (rejec
tion id: 1): CordovaError: Could not find an installed version of Gradle either
in Android Studio,
or on your system to install the gradle wrapper. Please include gradle
in your path, or install Android Studio
(node:4308) [DEP0018] DeprecationWarning: Unhandled promise rejections are depre
cated. In the future, promise rejections that are not handled will terminate the
 Node.js process with a non-zero exit code.
[15:09:32]  lint finished in 4.67 s

报错的原因:
cordova在6.4.0(cordova-android在6.1.2)之后,会要求安装Gradle,基于Gradle来编译、打包android。(具体版本号有待考证,但是需要安装Gradle属实)

解决办法:

1、手动下载gradle
gradle-x.x-bin.zip (x.x代表版本)
根据需要下载某一版本
地址: (https://services.gradle.org/distributions)
我下载的是gradle-4.1

下载完成后,解压到任意文件夹下

2、添加环境变量
PATH=D:\gradle-4.1\bin

3、关闭cmd

4、打开cmd,输入gradle -v,查看是否安装成功

5、继续使用ionic cordova build android。

阅读更多
版权声明:本文为博主gzgchzc原创文章,转载必须注明出处。http://blog.gzvtc.cc/ https://blog.csdn.net/qq_33561700/article/details/79107617
文章标签: ionic
个人分类: Ionic
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

不良信息举报

ionic升级到3.0之后,在使用命令:ionic cordova build android或者ionic cordova emulate android会提示以下错误

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭