Counterfeit Dollar

转自:      点击打开链接

Description

Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins. 
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs 
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively. 
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.

Input

The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A--L. Information on a weighing will be given by two strings of letters and then one of the words ``up'', ``down'', or ``even''. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.

Output

For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.

Sample Input

1 
ABCD EFGH even 
ABCI EFJK up 
ABIJ EFGH even 

Sample Output

K is the counterfeit coin and it is light. 

/* 
   功能Function Description:     POJ-1013 Counterfeit Dollar  策略问题
   开发环境Environment:          DEV C++ 4.9.9.1
   技术特点Technique:
   版本Version:
   作者Author:                     可笑痴狂
   日期Date:                     20120726
   备注Notes:
        由于该题必然有确定的判定,所以简单的可以这么想:
        设置一个标记数组,每次称球的时候,如果是"even"则把对应的设置为"真东西",即置为10,
        如果是"up"或"donw" 则把未分辨出真假的硬币中flag数组中对应的 ++ 或者 --,直到最后。那么操作之后,
        flag中存在没有辨认出真的,就是一系列的例如: -1,-2,1,2,3等数值,那么
        假东西就是其中绝对值最大的那个!!------被怀疑次数最多,所以它为假。
*/
#include<stdio.h>
#include<string.h>
#include<math.h>

int main()
{
    int n,k,i,t,len,max;
    char s1[13],s2[13],temp[10];
    int flag[12];
    scanf("%d",&n);
    while(n--)
    {
        memset(flag,0,sizeof(flag));
        for(t=1;t<=3;++t)
        {
            scanf("%s%s%s",s1,s2,temp);
            len=strlen(s1);              //两边个数肯定相等,所以两边长度也一样  
            if(strcmp(temp,"even")==0)
            {
                for(i=0;i<len;++i)
                {
                    flag[s1[i]-'A']=10;  //说明两边都为真,将标记数组置为10
                    flag[s2[i]-'A']=10;

                }
            }
            else if(strcmp(temp,"up")==0)//说明左边重
            {
                for(i=0;i<len;++i)
                {
                    if(flag[s1[i]-'A']!=10)
                        ++flag[s1[i]-'A'];  //左边加一
                    if(flag[s2[i]-'A']!=10)
                        --flag[s2[i]-'A'];  //右边减一

                }
            }
            else
            {
                for(i=0;i<len;++i)      //说明右边重
                {
                    if(flag[s1[i]-'A']!=10)
                        --flag[s1[i]-'A'];  //左边减一
                    if(flag[s2[i]-'A']!=10)
                        ++flag[s2[i]-'A'];  //右边加一
                }
            }
        }
        max=0;
        k=0;
        for(i=0;i<12;++i)
        {
            if(flag[i]==10)
                continue;
            if(max<=abs(flag[i]))
            {
                max=abs(flag[i]);
                k=i;
            }
        }
        if(flag[k]>0)
            printf("%c is the counterfeit coin and it is heavy.\n",'A'+k);
        else
            printf("%c is the counterfeit coin and it is light.\n",'A'+k);
    }
    return 0;
}


一道题往往有多解,不要被一道相当麻烦的解限制住,真正比赛时,当机立断,换个思路。


Stkcd [股票代码] ShortName [股票简称] Accper [统计截止日期] Typrep [报表类型编码] Indcd [行业代码] Indnme [行业名称] Source [公告来源] F060101B [净利润现金净含量] F060101C [净利润现金净含量TTM] F060201B [营业收入现金含量] F060201C [营业收入现金含量TTM] F060301B [营业收入现金净含量] F060301C [营业收入现金净含量TTM] F060401B [营业利润现金净含量] F060401C [营业利润现金净含量TTM] F060901B [筹资活动债权人现金净流量] F060901C [筹资活动债权人现金净流量TTM] F061001B [筹资活动股东现金净流量] F061001C [筹资活动股东现金净流量TTM] F061201B [折旧摊销] F061201C [折旧摊销TTM] F061301B [公司现金流1] F061302B [公司现金流2] F061301C [公司现金流TTM1] F061302C [公司现金流TTM2] F061401B [股权现金流1] F061402B [股权现金流2] F061401C [股权现金流TTM1] F061402C [股权现金流TTM2] F061501B [公司自由现金流(原有)] F061601B [股权自由现金流(原有)] F061701B [全部现金回收率] F061801B [营运指数] F061901B [资本支出与折旧摊销比] F062001B [现金适合比率] F062101B [现金再投资比率] F062201B [现金满足投资比率] F062301B [股权自由现金流] F062401B [企业自由现金流] Indcd1 [行业代码1] Indnme1 [行业名称1] 季度数据,所有沪深北上市公司的 分别包含excel、dta数据文件格式及其说明,便于不同软件工具对数据的分析应用 数据来源:基于上市公司年报及公告数据整理,或相关证券交易所、各部委、省、市数据 数据范围:基于沪深北证上市公司 A股(主板、中小企业板、创业板、科创板等)数据整理计算
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值