sliping windows

Description

An array of size  n ≤ 10  6 is given to you. There is a sliding window of size  k which is moving from the very left of the array to the very right. You can only see the  k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is  [1 3 -1 -3 5 3 6 7], and  k is 3.
Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7 -13
 1 [3  -1  -3] 5  3  6  7 -33
 1  3 [-1  -3  5] 3  6  7 -35
 1  3  -1 [-3  5  3] 6  7 -35
 1  3  -1  -3 [5  3  6] 7 36
 1  3  -1  -3  5 [3  6  7]37

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers  n and  k which are the lengths of the array and the sliding window. There are  nintegers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7


#include<iostream>
#include<deque>
#include<vector>
#include<cstdio>

using namespace std;

void minwindow(const vector<int>&record, int len)
{
	deque<int>r;
	for (int i = 0; i < len; ++i)
	{
		while (!r.empty() && record[i] < record[r.back()])
			r.pop_back();
		r.push_back(i);
	}
	   printf("%d ",record[r.front()]);
	for (int i = len; i < record.size(); ++i)
	{
		while (!r.empty() && record[i]<record[r.back()])
			r.pop_back();
		while (!r.empty() && i - len >= r.front())
			r.pop_front();
		r.push_back(i);
		if(i!=record.size()-1)
			printf("%d ", record[r.front()]);
		else
			printf("%d\n", record[r.front()]);
	}
	
}
void maxwindow(const vector<int>&record, int len)
{
	deque<int>r;
	for (int i = 0; i < len; ++i)
	{
		while (!r.empty() && record[i] > record[r.back()])
			r.pop_back();
		r.push_back(i);
	}
	printf("%d ",record[r.front()]);
	for (int i = len; i < record.size(); ++i)
	{
		while (!r.empty() && record[i]>record[r.back()])
			r.pop_back();
		while (!r.empty() && i - len >= r.front())
			r.pop_front();
		r.push_back(i);
		if (i != record.size() - 1)
			printf("%d ", record[r.front()]);
		else
			printf("%d\n", record[r.front()]);
	}
}
int main()
{
	int len, k;
	scanf("%d%d", &len, &k);
	vector<int>record;
	for (int i = 0; i < len; ++i)
	{
		int val;
		scanf("%d", &val);
		record.push_back(val);
	}
	 minwindow(record, k);

     maxwindow(record, k);

	//system("pause");
}

这道题并不难,当发现题目的时间限制很大(暗示输入量很大)时,TLE并不一定是算法设计的问题,

还有可能是一些小细节没做到优化。比如scanf,printf而不是cin,cout,数据可以直接输出的,就不要把数据储存后一起输出。


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值