poj 3278 Catch That Cow

1 篇文章 0 订阅

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

USACO 2007 Open Silver

/*
Problem: 3278  User: saruka 
Memory: 1000K  Time: 79MS 
Language: C++  Result: Accepted 
*/
#include <iostream>  
#include <queue>  
#include<cstdio>
#include<cstring>
#include<string>
#include<iomanip>
#include<algorithm>
#include<cmath>
#include<cstdlib>
using namespace std;
const int SIZE = 100001;
queue<int> q;
bool vis[SIZE];
int step[SIZE];
int bfs(int n, int k)
{
    int head, next;
    q.push(n);
    vis[n] = true; 
    step[n] = 0; 
    while (!q.empty())
    {
        head = q.front();  
        q.pop();
        for (int i = 0; i < 3; i++)                     
        {
            if (i == 0) next = head - 1;
            else if (i == 1) next = head + 1;
            else next = head * 2;
            if (next > SIZE || next < 0 || vis[next]) continue;
            if (!vis[next])
            {
                q.push(next); 
                step[next] = step[head] + 1; // 前一条路径数目,对应的走过的路程,即为当前的路程数
                vis[next] = true;
            }
            if (next == k) return step[next]; // 广搜的特性,返回的第一个一定是最短的路径
        }
    }
}
int main()
{
    int n, k;
    cin >> n >> k;
    if (n >= k) cout << n - k << endl;
    else cout << bfs(n, k) << endl;
    return 0;
}

Powered By Saruka.
Copyright © 2016 All Rights Reserved.

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值