PAT-Mars number

1100. Mars Numbers (20)
时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
People on Mars count their numbers with base 13:
Zero on Earth is called "tret" on Mars.
The numbers 1 to 12 on Earch is called "jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec" on Mars, respectively.
For the next higher digit, Mars people name the 12 numbers as "tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou", respectively.
For examples, the number 29 on Earth is called "hel mar" on Mars; and "elo nov" on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (< 100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.
Output Specification:
For each number, print in a line the corresponding number in the other language.
Sample Input:
4
29
5
elo nov
tam
Sample Output:
hel mar
may
115
13



本题题意就是在题目描述的火星数字规则下与阿拉伯数字的转换 输入一个阿拉伯数字 输出一个对应的火星文 输入一个火星文 输出一个对应的地球数字


本题需要注意的是 虽然没在题目中描述出来 但可以从样例中看到 当数字是13的整数倍时 不需要输出0----tret 只需要输出前面的取整的大数部分

如输入13时 只需要输出tam 不需要输出后面的0 其余情况就是13与10进制的转换问题了 通过查表和进制转换输出结果

本题在数据转换的时候可以利用stringstream

将string类型转化为int:

 stringstream s;

 string a;

 cin>>string;

 s<<a;

 int t;

 s>>t;

头文件:#include<sstream>

后来一直最后两个数据过不了 。。。查了好久后发现原来是low数组中的数据抄重了一个。。。- -初始化很重要!!!

#include<cstdio>
#include<stack>
#include<cmath>
#include<sstream>
#include<cstring>
#include<iostream>
using namespace std;
int main()
{
	int n;
	//0-24
	string low[]={  "tret","jan", "feb","mar" , "apr", "may", "jun", "jly", "aug", "sep", 
	"oct", "nov","dec","tam", "hel","maa", "huh", "tou", "kes", "hei", "elo", 
	"syy", "lok", "mer", "jou"};

	cin>>n;	
	getchar();
	while(n--)
	{
		string a;
		getline(cin,a);
		if(isdigit(a[0]))
		{
			stringstream s;
			s<<a;
			int t=0;
			s>>t;
			s.clear();
			
			string res;
			if(t<13)
				res.append(low[t]);
			else if(t%13==0)
				res.append(low[t/13+12]);
			else
			{
				stack<int>s;
				while(t){
					s.push(t%13);
					t/=13; 
				}	
				int d=s.top();s.pop();
				res.append(low[d+12]);
				res.append(" ");
				d=s.top();
				res.append(low[d]);
			} 
			cout<<res<<endl;
		}
		else
		{					
			int res=0;
			int pos=a.find(" ");
			if(pos!=-1)
				for(int i=0;i<=24;i++)
				{
					int lpos=a.find(low[i]);
					if(lpos!=-1&&lpos<pos){
						res+=(i-12)*13;
	//					cout<<(i-12)*13<<endl;
					}
					else if(lpos!=-1){
						res+=i;
	//					cout<<i<<endl;
					}
				}	
			else 
				for(int i=0;i<25;i++)
					if(a.find(low[i])!=-1&&i<13)res+=i;
					else if(a.find(low[i])!=-1)res+=(i-12)*13;
			cout<<res<<endl;
		}
	}
	return 0;
}







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值