总结:composer的install和require和update指令。到底什么时候用什么指令

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_33862644/article/details/79330398

白搭这篇博客了,下边有几张图糊了,从word粘过来的时候也没细看大哭

https://packagist.org  相当于是应用商店

其实看上面一个图就够了,下面是分析的思路

官网的教程:







在同一个项目中,假如使用3个类库,想一次一次安装。那么composer.json中最开始只有一个键值对类库。第一次使用composer install指令安装。添加第2个类库键值对开始后的每一次都是使用composer update指令安装

注意:下图的意思是,你只要执行require那行后,你vendor中假如100个类库,这100个类库就全部自动加载了,直接使用即可(不需要一个一个引入)


使用:

以下的截图,大家凑合看吧,看指令看意思就好了,千万不要细抠,因为这都是过去截的一些图,所以可能会是不同项目

安装指令:composer install


包含指令:composer require phpoffice/phpexcel





更新指令:composer update

注意:只有写在composer.json文件中的才能更新

加载成功:


按ait + enter 会弹出来,相当于use,因为我打开的是www目录。

如果只打开wslt这一个项目,且该项目中只有一个 该类库,就不需要选择(他选择的机会都不给你)




阅读更多

没有更多推荐了,返回首页