B - Charlie's Change

Charlie is a driver of Advanced Cargo Movement, Ltd. Charlie drives a
lot and so he often buys coffee at coffee vending machines at
motorests. Charlie hates change. That is basically the setup of your
next task.

Your program will be given numbers and types of coins Charlie has and
the coffee price. The coffee vending machines accept coins of values
1, 5, 10, and 25 cents. The program should output which coins Charlie
has to use paying the coffee so that he uses as many coins as
possible. Because Charlie really does not want any change back he
wants to pay the price exactly. Input Each line of the input contains
five integer numbers separated by a single space describing one
situation to solve. The first integer on the line P, 1 <= P <= 10 000,
is the coffee price in cents. Next four integers, C1, C2, C3, C4, 0 <=
Ci <= 10 000, are the numbers of cents, nickels (5 cents), dimes (10
cents), and quarters (25 cents) in Charlie’s valet. The last line of
the input contains five zeros and no output should be generated for
it. Output For each situation, your program should output one line
containing the string “Throw in T1 cents, T2 nickels, T3 dimes, and T4
quarters.”, where T1, T2, T3, T4 are the numbers of coins of
appropriate values Charlie should use to pay the coffee while using as
many coins as possible. In the case Charlie does not possess enough
change to pay the price of the coffee exactly, your program should
output “Charlie cannot buy coffee.”. Sample Input 12 5 3 1 2 16 0 0 0
1 0 0 0 0 0 Sample Output Throw in 2 cents, 2 nickels, 0 dimes, and 0
quarters. Charlie cannot buy coffee.


思路如下

这一题是让求我们 买一罐咖啡 最多能用多少个硬币,⚠️这题是我们 买一罐,我就是没有理解这一点,其次要买一罐咖啡,则支付的钱数,必定与与咖啡的价格相同,所以这是一个 需要特殊初始化状态dp[]的01背包,剩下的就是怎么初始化dp[]的问题,如果不会初始化 请点击传送门

题解如下
#include<iostream>
#include<string.h>

using namespace std;
const int Len = 10005;
int dp[Len];        //⚠️ 一定要注意 dp 使用来存生什么的,是用来存储使用各种硬币的总数量
int path[Len][2];   //在存储空背包空间为j时 path[j][0] 存储的的是在dp[j]状态下使用的那种硬币,path[j][1] 为在存储了某种硬币后 所剩余的空间
int coin[4] = {1,5,10,25};
int ans[26];        //存储每种硬币使用的数量
struct Node
{
    int num,all_pri,pri;    //在进行二进制拆分后得到的 得到的一种新的硬币 这种新硬币消耗原来的 num个硬币,新硬币的价值是 all_pri,原来硬币的价值是 pri
}a[Len];    //存储记录转移情况

int main()
{
    int cnt[4];
    int cost;
    while(scanf("%d%d%d%d%d",&cost,&cnt[0],&cnt[1],&cnt[2],&cnt[3]) && (cost + cnt[0] + cnt[1] + cnt[2] + cnt[3]))
    {
        int pos = 0;    //二进制拆分后物品变成 pos 件
        for(int t = 0;t < 4;t ++)
        {
            int count = cnt[t];
            //这里就是进行 二进制 拆分
            for(int k = 1;k <= count && k * coin[t] <= cost;k *= 2)
            {
                count -= k;
                a[pos].num = k;
                a[pos].all_pri = k * coin[t];
                a[pos ++].pri = coin[t];
            }
            if(count)       //二进制拆分的最后一个判读
            {
                a[pos].num = count;
                a[pos].all_pri = count * coin[t];
                a[pos ++].pri = coin[t];
            }
        }

        memset(dp,0,sizeof(dp));
        dp[0] = 1;      //⚠️这里恰好装满、使用完 情况初始化dp的技巧
        memset(path,0,sizeof(path));

        for(int i = 0;i < pos;i ++)
        {
            for(int j = cost;j >= a[i].all_pri;j --)
            {
                if(dp[j - a[i].all_pri] > 0 && dp[j - a[i].all_pri] + a[i].num > dp[j])
                {
                    dp[j] = dp[j - a[i].all_pri] + a[i].num; //在
                    path[j][0] = i;     //记录在 dp[j] 达到最大使用硬币使用数量时,消耗的是哪种硬币
                    path[j][1] = j - a[i].all_pri;  //dp[j]达到最大使用硬币数量时背包中剩余的空间 (这里的操作时 是为了 方便回推 )
                }
            }
        }
        if(!dp[cost])
        {
            printf("Charlie cannot buy coffee.\n");
        }
        else
        {
            memset(ans,0,sizeof(ans));
            int cost_ = cost;
            while(cost_)
            {
                int i = path[cost_][0]; // 在背包空间为j的情况时(dp[j])达到最优情况使用了 第i件物品
                ans[a[i].pri] += a[i].num; //使用第i种硬币时的 消耗 组成i硬币的某种硬币的数量
                cost_ = path[cost_][1]; //这一句就是要 往状态转移方程的上一个 状态回退,因为选则了 i 这种硬币,所以背包剩余的空间为 path[cost_][1]
            }
            printf("Throw in %d cents, %d nickels, %d dimes, and %d quarters.\n",ans[1],ans[5],ans[10],ans[25]);
        }
    }

    return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值