2016SDAU编程练习二1001

Can you solve this equation? 


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;<br>Now please try your lucky.
 


Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 


Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 


Sample Input
2<br>100<br>-4<br> 


Sample Output
1.6152<br>No solution!<br> 


题意:给Y的值,求x

思路:二分法求解,不断缩小范围就行

感想:比较基础吧,二分法还是很好用的

AC代码:

#include <cstdio>
#include<iostream>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<map>
#include<set>
#include<vector>
#include<iomanip>
using namespace std;
double q(double x)
{
    return 8*x*x*x*x+7*x*x*x+2*x*x+3*x+6;
}
int main()
{
    double x,y,h,l,mid;
    int n;
    cin>>n;
    while(n--)
    {


        cin>>y;
        if(q(0)>y||q(100)<y)
        {
            cout<<"No solution!"<<endl;
            continue;
        }
        h=100;
        l=0;
        while((h-l)>0.00000001)
        {
            mid=(h+l)/2;
            if(q(mid)>y)
            h=mid;
            else l=mid;
        }
        printf("%.4f\n",mid);
    }


}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值