hdu 1532 Drainage Ditches (最大流—EK算法)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1532


Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15490    Accepted Submission(s): 7383


Problem Description
Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 
 

Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
 

Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond. 
 

Sample Input
  
  
5 4 1 2 40 1 4 20 2 4 20 2 3 30 3 4 10
 

Sample Output
  
  
50
 

Source

题目大意:农民约翰知道不仅多少加仑水每沟可以每分钟输送而且沟渠,它在一个潜在的复杂网络送出的池塘和成彼此并流的确切布局。
                    鉴于所有这些信息,确定在哪些水可以运出的池塘和进流的最大速率。给出u-> v 的流量,然后求最大流量

解析:EK算法链接:http://www.cnblogs.com/o8le/archive/2011/11/18/2254617.html     


代码如下:

#include<iostream>
#include<algorithm>
#include<map>
#include<stack>
#include<queue>
#include<set>
#include<string>
#include<cstdio>
#include<cstring>
#include<cctype>
#include<cmath>
#define N 509
using namespace std;
const int inf = 1e9;
const int mod = 1<<30;
const double eps = 1e-8;
const double pi = acos(-1.0);
typedef long long LL;

int mp[N][N], book[N], pre[N];
int n;
int max_flow()
{
    int i, u, ans = 0;
    while(1)
    {
        memset(book, 0, sizeof(book));
        memset(pre, 0, sizeof(pre));
        queue<int> q;
        book[1] = 1;
        q.push(1);
        while(!q.empty())
        {
            u = q.front();
            q.pop();
            if(u == n) break;
            for(i = 1; i <= n; i++)
            {
                if(!book[i] && mp[u][i] > 0)
                {
                    book[i] = 1;
                    q.push(i);
                    pre[i] = u;
                }
            }
        }
        if(!book[n]) break;
        int M = inf;
        for(i = n; i != 1; i = pre[i])
        {
            M = min(M, mp[pre[i]][i]);
        }
        for(i = n; i != 1; i = pre[i])
        {
            mp[pre[i]][i] -= M;
            mp[i][pre[i]] += M;
        }
        ans += M;
    }
    return ans;
}

int main()
{
    int m, u, v, w, i;
    while(~scanf("%d%d", &m, &n))
    {
        memset(mp, 0, sizeof(mp));
        for(i = 1; i <= m; i++)
        {
            scanf("%d%d%d", &u, &v, &w);
            mp[u][v] += w;
        }
        int ans = max_flow();
        printf("%d\n", ans);
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值