poj 3278 Catch That Cow(BFS)

题目链接:http://poj.org/problem?id=3278


Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 77552 Accepted: 24508

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top




题目大意:在一个数轴上,两个位置,农场主站在n位置上,牛在k位置上,农场主想抓住这个牛,问最少多少时间抓到牛,可以走x+1、x-1、x * 2

解析:bfs , 开一个数组标记走过的位置,不管怎么走,肯定是能找到的,找到退出

代码如下:

#include<iostream>
#include<algorithm>
#include<map>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<string>
#include<cstdio>
#include<cstring>
#include<cctype>
#include<cmath>
#define N 100009
using namespace std;
const int inf = 1e9;
const int mod = 1<<30;
const double eps = 1e-8;
const double pi = acos(-1.0);
typedef long long LL;
struct node
{
    int s, n;
};
int s, e;
int vis[N];

int bfs()
{
    memset(vis, 0, sizeof(vis));
    queue<node> q;
    node now, nx;
    now.s = s; now.n = 0;
    q.push(now);
    vis[now.s] = 1;
    while(!q.empty())
    {
        now = q.front(); q.pop();
        if(now.s == e) return now.n;

        nx = now; nx.n++; nx.s++;
        if(nx.s <= 100000 && !vis[nx.s]) { q.push(nx); vis[nx.s] = 1;}

        nx = now; nx.s--; nx.n++;
        if(nx.s >= 0 && !vis[nx.s]) { q.push(nx); vis[nx.s] = 1;} //注意0,不能小于0,不然RE

        nx = now; nx.s *= 2; nx.n++;
        if(nx.s <= 100000 && !vis[nx.s]) { q.push(nx); vis[nx.s] = 1;}

    }
    return 0;
}

int main()
{
    scanf("%d%d", &s, &e);
    int ans = bfs();
    printf("%d\n", ans);
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值