hdu 2639 Bone Collector II(0-1 + 路径)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2639


Bone Collector II

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4288    Accepted Submission(s): 2230


Problem Description
The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:

Here is the link: http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.
 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the K-th maximum of the total value (this number will be less than 2 31).
 

Sample Input
  
  
3 5 10 2 1 2 3 4 5 5 4 3 2 1 5 10 12 1 2 3 4 5 5 4 3 2 1 5 10 16 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
12 2 0
 

Author
teddy
 

Source
 

Recommend
teddy
 

Statistic |  Submit |  Discuss |  Note


题目大意:骨头收集者有容量为C的背包,求所能装的第 k 大价值

题目解析:0-1 + 路径,把所有状态都记录下,每次都排下序,dp[N][N] 建成二维,dp[i][j]表示容量为 i 时的第 j 大价值


代码如下:


#include<iostream>
#include<algorithm>
#include<map>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<string>
#include<cstdio>
#include<cstring>
#include<cctype>
#include<cmath>
#define N 1009
using namespace std;
const int inf = 1e9;
const int mod = 1<<30;
const double eps = 1e-8;
const double pi = acos(-1.0);
typedef long long LL;

int dp[N][66], a[110], b[110];
int pre[66], cur[66];

int main()
{
    int n, v, k, i, j, t;
    cin >> t;
    while(t--)
    {
        scanf("%d%d%d", &n, &v, &k);
        for(i = 1; i <= n; i++) scanf("%d", &a[i]);
        for(i = 1; i <= n; i++) scanf("%d", &b[i]);
        memset(dp, 0, sizeof(dp));
        //memset(pre, 0, sizeof(pre));
        //memset(cur, 0,sizeof(cur));
        for(i = 1; i <= n; i++)
        {
            for(j = v; j >= b[i]; j--)
            {
                for(int r = 1; r <= k; r++)
                {
                    pre[r] = dp[j - b[i]][r] + a[i]; //前一个状态
                    cur[r] = dp[j][r];  //当前状态
                }
                int w, x, y;
                pre[k + 1] = cur[k + 1] = -1;
                w = x = y = 1;
                while(w <= k && (x <= k || y <= k))
                {
                    if(pre[x] > cur[y]) dp[j][w] = pre[x++];
                    else dp[j][w] = cur[y++];
                    if(w == 1 || dp[j][w] != dp[j][w - 1]) w++;
                }
            }
        }
        printf("%d\n", dp[v][k]);
    }
    return 0;
}
















  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值