hdu 3466 Proud Merchants (0-1 + 排序)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3466


Proud Merchants

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 5564    Accepted Submission(s): 2343


Problem Description
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?

 

Input
There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

 

Output
For each test case, output one integer, indicating maximum value iSea could get.

 

Sample Input
  
  
2 10 10 15 10 5 10 5 3 10 5 10 5 3 5 6 2 7 3
 

Sample Output
  
  
5 11
 

Author
iSea @ WHU
 

Source
 

Recommend
zhouzeyong
 


题目大意:一件物品价格p,手里要求钱最少q,价值v,一个人手里有n元钱,求他所获得的最大价值

题目解析:0-1背包,要想获得价值大,要q -  p进行从小到大排序,还必须q - p 从小的开始买,如果先买q - p大的,

                    那么j - p[i]不能保证一定 > 之前所买q - p 大的q 


代码如下:


#include<iostream>
#include<algorithm>
#include<map>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<string>
#include<cstdio>
#include<cstring>
#include<cctype>
#include<cmath>
#define N 5009
using namespace std;
const int inf = 1e9;
const int mod = 1<<30;
const double eps = 1e-8;
const double pi = acos(-1.0);
typedef long long LL;

struct node
{
    int p, q, v;
}t[N];
int dp[N];
bool cmp(node a, node b)
{
    return a.q - a.p < b.q - b.p;
}

int main()
{
    int n, c, i, j;
    while(~scanf("%d%d", &n, &c))
    {
        for(i = 1; i <= n; i++) scanf("%d%d%d", &t[i].p, &t[i].q, &t[i].v);
        sort(t + 1, t + n + 1, cmp);
        memset(dp, 0, sizeof(dp));
        for(i = 1; i <= n; i++)
        {
            for(j = c; j >= t[i].q; j--)
            {
                dp[j] = max(dp[j], dp[j - t[i].p] + t[i].v);
            }
        }
        printf("%d\n", dp[c]);
    }
    return 0;
}








评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值