POJ 3122 Pie(二分逼近)

题目链接:http://poj.org/problem?id=3122


Pie
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15777 Accepted: 5386 Special Judge

Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though. 

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:
  • One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10 −3.

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655

Source

[Submit]   [Go Back]   [Status]   [Discuss]





题目大意:生日时,给朋友们分馅饼,要求分n + 1个人,面积相等,形状可以不一样,但每个人分得的馅饼必须来自一块馅饼,求分得的S最大

题目解析:二分半径的平方,二分半径会WA,二分面积比较费时,注意用acos(-1.0)求PI,不然会WA,这个题就是精度要求高


代码如下:


#include<iostream>
#include<algorithm>
#include<map>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<string>
#include<cstdio>
#include<cstring>
#include<cctype>
#include<cmath>
#define N 10009
using namespace std;
const int inf = 1e9;
const int mod = 1<<30;
const double eps = 1e-8;
const double pi = acos(-1.0);
typedef long long LL;
double a[N];

int main()
{
    int t, m, n, i;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d", &m, &n);
        n = n + 1;
        double l = 0, r = 0;
        for(i = 1; i <= m; i++){
            scanf("%lf", &a[i]);
            a[i] = a[i] * a[i];
            r = max(r, a[i]);
        }

        while(r - l > eps)
        {
            double md = (l + r) / 2.0;
            int k = 0;
            for(i = 1; i <= m; i++)
            {
                k = k + (int)(1.0 * a[i] / md);
            }
            if(k >= n) l = md;
            else r = md;
        }
        double s = pi * l;
        printf("%.4f\n", s);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值