poj 3159 Candies(差分约束)

题目链接:http://poj.org/problem?id=3159


Candies
Time Limit: 1500MS Memory Limit: 131072K
Total Submissions: 33163 Accepted: 9296

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow Mlines each holding three integers AB and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4

Sample Output

5

Hint

32-bit signed integer type is capable of doing all arithmetic.

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top


解析:有n个人分糖果,m个限制,a, b, c就是 b - a <= c,问n比1最多 多 多少,如果最小,直接为0,c为0即可;如果要最大,那c等于c就行了,求下最短路,vector邻接表会超时,需要用链式前向星,dij用优先队列优化下才能过

代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<vector>
#include<queue>
using namespace std;
typedef long long LL;
const int Max_V = 50009;
const int INF = 0x3f3f3f3f;


struct edge
{
    int to, w, nx;
}mp[150009];

int cnt, head[Max_V];

typedef pair<int, int> P;  // first 是最短距离,second是顶点编号
int V;
int d[Max_V];


inline bool scan_d(int &num)
{
        char in;bool IsN=false;
        in=getchar();
        if(in==EOF) return false;
        while(in!='-'&&(in<'0'||in>'9')) in=getchar();
        if(in=='-'){ IsN=true;num=0;}
        else num=in-'0';
        while(in=getchar(),in>='0'&&in<='9'){
                num*=10,num+=in-'0';
        }
        if(IsN) num=-num;
        return true;
}

void add(int u, int v, int w)
{
    mp[cnt].to = v;
    mp[cnt].w = w;
    mp[cnt].nx = head[u];
    head[u] = cnt++;
}


void dijkstra(int s)
{
    //通过指定greater<P>参数,堆按照first从小到大的循序取出值
    priority_queue<P, vector<P>, greater<P> > que;
    memset(d, 0x3f, sizeof(d));
    d[s] = 0;
    que.push(P(0, s));

    while(!que.empty())
    {
        P p = que.top();
        que.pop();
        int v = p.second;
        if(d[v] < p.first) continue;
        for(int i = head[v]; ~i; i = mp[i].nx)
        {
            int u = mp[i].to;
            if(d[u] > d[v] + mp[i].w)  d[u] = d[v] + mp[i].w, que.push(P(d[u], u));
        }
    }
}


int main()
{
    int u, v, w, m;
    while(~scanf("%d%d", &V, &m))
    {
        memset(head, -1, sizeof(head));
        cnt = 0;
        for(int i = 1; i <= m; i++)
        {
            scan_d(u); scan_d(v); scan_d(w);
            add(u, v, w);
        }
        dijkstra(1);
        printf("%d\n", d[V]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值