hdu 2586 How far away ? (LCA转RMQ)

43 篇文章 0 订阅
17 篇文章 0 订阅

题目链接:http://acm.split.hdu.edu.cn/showproblem.php?pid=2586

How far away ?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 18268    Accepted Submission(s): 7106


Problem Description
There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.
 

Input
First line is a single integer T(T<=10), indicating the number of test cases.
  For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n.
  Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.
 

Output
For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.
 

Sample Input
  
  
2 3 2 1 2 10 3 1 15 1 2 2 3 2 2 1 2 100 1 2 2 1
 

Sample Output
  
  
10 25 100 100
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   3486  2874  2888  3234  2818 
 

Statistic |  Submit |  Discuss |  Note

解析:裸的模板Lca,距离[u->v] = dis[u] + dis[v] - 2*dis[lca]; dis[k]代表节点k到树根的距离

代码:

#include<bits/stdc++.h>
using namespace std;

struct node
{
    int to, val;
};

vector<node> mp[40001];
int n, m;
int fr[40001], dep[40001], dis[40001];
int zx, vis[40001], visnum[80001];
int dp[80001][20];



void creat(int u, int k, int d)
{
    dep[u] = k;
    dis[u] = d;
    for(int i = 0; i < mp[u].size(); i++)
    {
        node cur = mp[u][i];
        vis[u] = zx;
        visnum[zx++] = u;
        creat(cur.to, k+1, d+cur.val);
    }
    vis[u] = zx;
    visnum[zx++] = u;
}

void rmq()
{
    int s = n*2-1;
    for(int i = 1; i <= s; i++) dp[i][0] = visnum[i];
    for(int j = 1; j != 20; j++)
    {
        for(int i = 1; i <= s; i++)
        {
            if(i + (1<<j) - 1 > s) continue;
            if(dep[dp[i][j - 1]] < dep[dp[i + (1<<j>>1)][j - 1]]) dp[i][j] = dp[i][j - 1];
            else dp[i][j] = dp[i + (1<<j>>1)][j - 1];
        }
    }
}

int lca(int x, int y)
{
    int k = 0;
    while((1<<k) < y-x+1) k++;
    k--;
    int ans;
    if(dep[dp[y - (1<<k)+1][k]] < dep[dp[x][k]]) ans = dp[y - (1<<k)+1][k];
    else ans = dp[x][k];
    return ans;
}


int main()
{
    int t;
    node cur;
    scanf("%d", &t);
    while(t--)
    {
        int u, v, w;
        scanf("%d%d", &n, &m);
        for(int i = 1; i <= n; i++) mp[i].clear();
        for(int i = 1; i <= n; i++) fr[i] = i;
        for(int i = 1; i < n; i++)
        {
            scanf("%d%d%d", &u, &v, &w);
            cur.to = v; cur.val = w;
            mp[u].push_back(cur);
            fr[v] = u;
        }
        while(fr[u] != u) u = fr[u];
        zx = 1;
        creat(u, 1, 0);
        rmq();
        while(m--)
        {
            scanf("%d%d", &u, &v);
            int lca_;
            if(vis[u] < vis[v]) lca_ = lca(vis[u], vis[v]);
            else lca_ = lca(vis[v], vis[u]);
            printf("%d\n", dis[u] + dis[v] - 2*dis[lca_]);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值