POJ3083 DFS+BFS

Children of the Candy Corn
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14239 Accepted: 6157

Description

The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombies, chainsaw-wielding psychopaths, hippies, and other terrors on their quest to find the exit. 

One popular maze-walking strategy guarantees that the visitor will eventually find the exit. Simply choose either the right or left wall, and follow it. Of course, there's no guarantee which strategy (left or right) will be better, and the path taken is seldom the most efficient. (It also doesn't work on mazes with exits that are not on the edge; those types of mazes are not represented in this problem.) 

As the proprieter of a cornfield that is about to be converted into a maze, you'd like to have a computer program that can determine the left and right-hand paths along with the shortest path so that you can figure out which layout has the best chance of confounding visitors.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of mazes. Each maze will consist of one line with a width, w, and height, h (3 <= w, h <= 40), followed by h lines of w characters each that represent the maze layout. Walls are represented by hash marks ('#'), empty space by periods ('.'), the start by an 'S' and the exit by an 'E'. 

Exactly one 'S' and one 'E' will be present in the maze, and they will always be located along one of the maze edges and never in a corner. The maze will be fully enclosed by walls ('#'), with the only openings being the 'S' and 'E'. The 'S' and 'E' will also be separated by at least one wall ('#'). 

You may assume that the maze exit is always reachable from the start point.

Output

For each maze in the input, output on a single line the number of (not necessarily unique) squares that a person would visit (including the 'S' and 'E') for (in order) the left, right, and shortest paths, separated by a single space each. Movement from one square to another is only allowed in the horizontal or vertical direction; movement along the diagonals is not allowed.

Sample Input

2
8 8
########
#......#
#.####.#
#.####.#
#.####.#
#.####.#
#...#..#
#S#E####
9 5
#########
#.#.#.#.#
S.......E
#.#.#.#.#
#########

Sample Output

37 5 5
17 17 9

Source

 
 
// POJ3083.cpp : 定义控制台应用程序的入口点。
//

#include<iostream>
#include<cstring>
#include<queue>
#include<string>
#define maxn 43
#define UP 1
#define DOWN 3
#define LEFT 0
#define RIGHT 2
using namespace std;
int map[maxn][maxn];
int n, m;
int sx, sy, dx, dy;
int dirx[4] = { 0,-1,0,1 }; //左上右下
int diry[4] = { -1,0,1,0 };
string name[4] = { "left","up","right","down" };
int dir;
int vis[maxn][maxn];

int dfs(int dr,int cur, int x, int y,int step) {
	if (x == dx && y == dy) {
		return step;
	}
	int k = (cur +4+ dr)%4;
	int ans;
	for (int i = 0; i < 4; i++) {
		int xx = x + dirx[k], yy = y + diry[k];
		if (xx >= 1 && xx <= n&&yy >= 1 && y <= m && map[xx][yy]) {
			//if (step < 30)cout << name[k] << " :" << xx << "  " << yy << endl;
			//vis[xx][yy] = 1;
			if ((ans = dfs(dr, k, xx, yy, step + 1))) {
				return ans;
			}
			//vis[xx][yy] = 0;
		}
		k = (k - dr +4 ) % 4;
	}
	return 0;
}
struct node {
	int x, y,  step;
	node(int xx, int yy, int ss) {
		x = xx, y = yy, step = ss;
	}
};
int bfs() {
	//memset(vis, 0, sizeof(vis));
	queue<node>Q;
	Q.push(node(sx, sy, 1));
	while (!Q.empty()) {
		node a = Q.front();
		Q.pop();
		if (a.x == dx && a.y == dy) {
			return a.step;
		}
		int x = a.x, y = a.y, step = a.step;
		for (int i = 0; i < 4; i++) {
			int xx = x + dirx[i], yy = y + diry[i];
			if (xx >= 1 && xx <= n&&yy >= 1 && y <= m && map[xx][yy]) {
				map[xx][yy] = 0;
				Q.push(node(xx, yy, step + 1));
			}
		}
	}
	return 0;
}
void solve() {
	cout << dfs(-1, dir, sx, sy, 1) << " ";
	cout << dfs(1, dir, sx, sy, 1) << " ";
	cout << bfs()<<endl;
}
int main()
{
	int k;
	char s[maxn];
	scanf("%d", &k);
	while (k--) {
		scanf("%d%d", &m, &n);
		for (int i = 1; i <= n; i++) {
			scanf("%s", s+1);
			for (int j = 1; j <= m; j++) {
				if (s[j] == '#') {
					map[i][j] = 0;
				}
				else {
					map[i][j] = 1;
					if (s[j] == 'S') {
						sx = i, sy = j;
						if (i == 0) {
							dir = DOWN;
						}
						else if (i == n - 1) {
							dir = UP;
						}
						else if (j == 0) {
							dir = RIGHT;
						}
						else {
							dir = LEFT;
						}
					}
					else if (s[j] == 'E') {
						dx = i, dy = j;
					}
				}
			}
		}
		solve();
	}



    return 0;
}


 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值