【PAT甲级】1041 Be Unique(散列)

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10​4​​]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10​5​​) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

 题目大意

这题就是要找到一个数列中的第一个在整个数列中唯一的数字,如果没有则输出None

个人思路

这题是散列算法的应用。设立一个统计个数的数组num_cnt[],num_cnt[i]表示i在数列中出现的次数,然后输出数列中第一个数量为1的数字即可,如果没有则输出None

代码实现

#include <cstdio>
#include <cstring>
#include <string>
#include <set>
#include <map>
#include <vector>
#include <cmath>
#include <algorithm>
#include <iostream>
#define ll long long
#define eps 1e-8
#define INF 0x7FFFFFFF
using namespace std;
const int maxn = 100005;
const int maxm = 10005;
int nums[maxn];
int nums_cnt[maxm];

int main() {
    // 初始化
    memset(nums_cnt, 0, sizeof(nums_cnt));
    // 输入并统计个数
    int n;
    cin >> n;
    for (int i = 0; i < n; i ++) {
        cin >> nums[i];
        nums_cnt[nums[i]] ++;
    }
    // 输出
    for (int i = 0; i < n; i ++) {
        if (nums_cnt[nums[i]] == 1) {
            cout << nums[i] << endl;
            return 0;
        }
    }
    cout << "None" << endl;
    return 0;
}

总结

学习不息,继续加油

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值