ZOJ 3929 Deque and Balls

There are n balls, where the i-th ball is labeled as pi. You are going to put n balls into a deque. In the i-th turn, you need to put the i-th ball to the deque. Each ball will be put to both ends of the deque with equal probability.

Let the sequence (x1x2, ..., xn) be the labels of the balls in the deque from left to right. The beauty of the deque B(x1x2, ..., xn) is defined as the number of descents in the sequence. For the sequence (x1x2, ..., xn), a descent is a position i (1 ≤ i < n) with xi > xi+1.

You need to find the expected value of B(x1x2, ..., xn).

Deque is a double-ended queue for which elements can be added to or removed from either the front (head) or the back (tail).

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains an integer n (2 ≤ n ≤ 100000) -- the number of balls. The second line contains n integers: p1p2, ..., pn (1 ≤ pi ≤ n).

Output

For each test case, if the expected value is E, you should output E⋅2n mod (109 + 7).

Sample Input
2
2
1 2
3
2 2 2
Sample Output
2
0
 
给出n个数字放入队列中,可以放在队列的前面也可以放在队列的后面,问得到xi>xi+1的概率
(就是数出有多少xi>xi+1然后除以总共可能的情况),由于最后要求将所得的数字乘以2^n,
所以也就是将得到的个数乘以二就是最后答案;
这里举个例子
3
1 2 3
 				1
		12				21
	123		231		321		213
      (没有)	      (31一个)       (32.21两个)    (21一个)
总共4个,乘以2后答案是8
 
 
AC代码:
#include<bits/stdc++.h>  
using namespace std;  
#define mod 1000000007  
long long ans[100005];//存的是从0-当前位置,递减数对的个数,可递推  
  
//就是当前的可配对数,就是先前已经匹配好的*2+当前增加的  
  
long long r[100005];//记录相同数对当前数的影响  
long long power[100005];//2的幂  
int n,t,a;  
int main()  
{  
    power[1]=1;  
    for(int i=2; i<=100000; i++)//预处理部分  
        power[i]=(power[i-1]*2)%mod;  
    cin>>t;  
    while(t--)  
    {  
        memset(ans,0,sizeof(ans));  
        memset(r,0,sizeof(r));  
        cin>>n;  
        for(int i=1; i<=n; i++)  
        {  
            cin>>a;  
            ans[i]=(ans[i-1]*2+power[i-1]-r[a]+mod)%mod;  
            //翻译上面一行:  
            //这个状态的可能值=上个状态可行的对数*2(因为我这个数放下去不影响之前就匹配好的数,但是放下去有两种可能性。  
            //                                       例如:21,然后后边不管多少个数,这个21数对总是需要被计算进去)  
            //  
            //                +放下这个数后所有的可能性(每放下一个数,这个串就像二叉树一样在生长)  
            //                -相同数造成的影响(如果这个数是第一次出现,那么总是可以放在比他大的数的右边,同理也可以放在比他小的左边)  
            //                  那么这个数的对这个状态先前的所有数都有影响。然后再后来出现这个数的时候要减去先前已经造成的影响。  
            //                  最后+mod是因为power被mod过,可能比r[a]大,(但是mod前实际是不会的)  
            //                 然后最后取模  
            //关于这个power[i-1],我再解释下,比如21 12 ,你将要放下3,你一定可以放在一个地方使得
            //总共的xi>xi+1多一个,比如这个你可以放在21的左边.还有12的左边,分别会多出一个32和31.
            //这个就是power[i-1]=power[2]=2;
            //还有那个r[a]也是类似的方式去理解;
            if(i==1)  
                r[a]=(r[a]+1)%mod;  
            else  
                r[a]=(r[a]+power[i-1])%mod;  
            //cout<<ans[i]<<endl;  
        }  
        cout<<(2*ans[n])%mod<<endl;  
    }  
    return 0;  
} 
 
比赛的时候队友题目翻译错了,我也没有去认真读题,于是也没有做出来,赛后问了下学长,才稍微懂了点。
 
转自http://blog.csdn.net/tinyguyyy/article/details/51133548(稍微加了点自己的的理解)
在使用Python来安装geopandas包时,由于geopandas依赖于几个其他的Python库(如GDAL, Fiona, Pyproj, Shapely等),因此安装过程可能需要一些额外的步骤。以下是一个基本的安装指南,适用于大多数用户: 使用pip安装 确保Python和pip已安装: 首先,确保你的计算机上已安装了Python和pip。pip是Python的包管理工具,用于安装和管理Python包。 安装依赖库: 由于geopandas依赖于GDAL, Fiona, Pyproj, Shapely等库,你可能需要先安装这些库。通常,你可以通过pip直接安装这些库,但有时候可能需要从其他源下载预编译的二进制包(wheel文件),特别是GDAL和Fiona,因为它们可能包含一些系统级的依赖。 bash pip install GDAL Fiona Pyproj Shapely 注意:在某些系统上,直接使用pip安装GDAL和Fiona可能会遇到问题,因为它们需要编译一些C/C++代码。如果遇到问题,你可以考虑使用conda(一个Python包、依赖和环境管理器)来安装这些库,或者从Unofficial Windows Binaries for Python Extension Packages这样的网站下载预编译的wheel文件。 安装geopandas: 在安装了所有依赖库之后,你可以使用pip来安装geopandas。 bash pip install geopandas 使用conda安装 如果你正在使用conda作为你的Python包管理器,那么安装geopandas和它的依赖可能会更简单一些。 创建一个新的conda环境(可选,但推荐): bash conda create -n geoenv python=3.x anaconda conda activate geoenv 其中3.x是你希望使用的Python版本。 安装geopandas: 使用conda-forge频道来安装geopandas,因为它提供了许多地理空间相关的包。 bash conda install -c conda-forge geopandas 这条命令会自动安装geopandas及其所有依赖。 注意事项 如果你在安装过程中遇到任何问题,比如编译错误或依赖问题,请检查你的Python版本和pip/conda的版本是否是最新的,或者尝试在不同的环境中安装。 某些库(如GDAL)可能需要额外的系统级依赖,如地理空间库(如PROJ和GEOS)。这些依赖可能需要单独安装,具体取决于你的操作系统。 如果你在Windows上遇到问题,并且pip安装失败,尝试从Unofficial Windows Binaries for Python Extension Packages网站下载相应的wheel文件,并使用pip进行安装。 脚本示例 虽然你的问题主要是关于如何安装geopandas,但如果你想要一个Python脚本来重命名文件夹下的文件,在原始名字前面加上字符串"geopandas",以下是一个简单的示例: python import os # 指定文件夹路径 folder_path = 'path/to/your/folder' # 遍历文件夹中的文件 for filename in os.listdir(folder_path): # 构造原始文件路径 old_file_path = os.path.join(folder_path, filename) # 构造新文件名 new_filename = 'geopandas_' + filename # 构造新文件路径 new_file_path = os.path.join(folder_path, new_filename) # 重命名文件 os.rename(old_file_path, new_file_path) print(f'Renamed "{filename}" to "{new_filename}"') 请确保将'path/to/your/folder'替换为你想要重命名文件的实际文件夹路径。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值