jdk报错


Syntax error, annotations are only available if source level is 1.5 or greater解决方法





原创

2016年07月18日 14:13:39

        <ul class="article_tags clearfix csdn-tracking-statistics tracking-click" data-mod="popu_377">
            <li class="tit">标签:</li>


  • java /






  • import一个项目进MyEclipse,原项目jdk版本用的1.8,tomcat8.0,现在我的环境是tomcat6.0,jdk1.7,报错。
    在下图所示,点击jre System Liabrary,选择edit,更改jdk版本为1.7:
    这里写图片描述
    然后在java代码的@Override等处报错“Syntax error, annotations are only available if source level is 1.5 or greater”,解决办法如下图,在
    project facets中,修改java版本为1.7,问题解决。
    这里写图片描述





    $(".MathJax").remove();

    阅读更多
    想对作者说点什么?

    博主推荐

    换一批

    没有更多推荐了,返回首页