Codeforces Educational Codeforces Round 105 A. ABC String c++

A. ABC String

You are given a string a, consisting of n characters, n is even. For each i from 1 to n ai is one of ‘A’, ‘B’ or ‘C’.

A bracket sequence is a string containing only characters “(” and “)”. A regular bracket sequence is a bracket sequence that can be transformed into a correct arithmetic expression by inserting characters “1” and “+” between the original characters of the sequence. For example, bracket sequences “()()” and “(())” are regular (the resulting expressions are: “(1)+(1)” and “((1+1)+1)”), and “)(”, “(” and “)” are not.

You want to find a string b that consists of n characters such that:

b is a regular bracket sequence;
if for some i and j (1≤i,j≤n) ai=aj, then bi=bj.
In other words, you want to replace all occurrences of ‘A’ with the same type of bracket, then all occurrences of ‘B’ with the same type of bracket and all occurrences of ‘C’ with the same type of bracket.

Your task is to determine if such a string b exists.

Input
The first line contains a single integer t (1≤t≤1000) — the number of testcases.

Then the descriptions of t testcases follow.

The only line of each testcase contains a string a. a consists only of uppercase letters ‘A’, ‘B’ and ‘C’. Let n be the length of a. It is guaranteed that n is even and 2≤n≤50.

Output
For each testcase print “YES” if there exists such a string b that:

b is a regular bracket sequence;
if for some i and j (1≤i,j≤n) ai=aj, then bi=bj.
Otherwise, print “NO”.

You may print every letter in any case you want (so, for example, the strings yEs, yes, Yes and YES are all recognized as positive answer).

输入样例
4
AABBAC
CACA
BBBBAC
ABCA

输出样例
YES
YES
NO
NO

解题思路

这道题我的思路是先按照出现次数找到相应的A,B,C
然后按照首字母分为两种情况
然后就是找前i(1<i<size)个字母时候存在")“的数量是否大于”(",如果存在那么输出NO,结束
如果一直都可以运行,就输出YES

AC代码

#include <iostream>
#include <cstring>
using namespace std;
int A,B,C;
int main() {
   
	int n;
	cin>>n;
	getchar();
	while(n--) {
   
		int
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Nebula_xuan

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值