C - Phone List POJ - 3630(tire 字典树)

该博客介绍了如何使用C语言解决POJ - 3630问题,即检查电话号码列表是否一致,避免一个号码是另一个号码的前缀。博主分享了解题思路和AC代码,通过字典树模板来判断电话号码列表的前缀冲突情况。
摘要由CSDN通过智能技术生成

C - Phone List POJ - 3630

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:

Emergency 911
Alice 97 625 999
Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output “YES” if the list is consistent, or “NO” otherwise.

Sample Input
2
3
911
97625999
91125426
5
113
12340
123440
12345
98346
Sample Output
NO
YES

解题思路

字典树模板题,每次插入的时候顺便进行判断操作,如果每次操作都有新的分支进入并且前缀没有前面存在过的单词,则返回true,如果存在false,则输出NO即可,反之输出YES

AC代码

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
using namespace std;
const int N = 100010;
int son[N][27], cnt;
bool vis[N];
char aa[20];
int t,n;
bool insert() {
	int cur= 0;
	bool flag1=false,flag2=false;
	for (int i = 0; aa[i]; i++) {
		int u = aa[i] - '0';
		if (!son[cur][u]) {
			son[cur][u] = ++cnt;
			flag1=true;
		}
		cur = son[cur][u];
		if (vis[cur])
			flag2 = true;
	}
	vis[cur]=true;
	return flag1&&!flag2;
}
int main() {

	scanf("%d",&t);
	while (t--) {
		memset(son, 0, sizeof son);
		memset(vis, false, sizeof vis);
		bool flag = true;
		cnt = 0;
		scanf("%d",&n);
		while (n--) {
			scanf("%s",aa);
			if(!insert())flag=false;
		}
		if (flag)
			puts("YES");
		else
			puts("NO");
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zengyz-wh

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值