7-55 查询水果价格

给定四种水果,分别是苹果(apple)、梨(pear)、桔子(orange)、葡萄(grape),单价分别对应为3.00元/公斤、2.50元/公斤、4.10元/公斤、10.20元/公斤。

首先在屏幕上显示以下菜单:

[1] apple
[2] pear
[3] orange
[4] grape
[0] exit

用户可以输入编号1~4查询对应水果的单价。当连续查询次数超过5次时,程序应自动退出查询;不到5次而用户输入0即退出;输入其他编号,显示价格为0。

输入格式:

输入在一行中给出用户连续输入的若干个编号。

输出格式:

首先在屏幕上显示菜单。然后对应用户的每个输入,在一行中按格式“price = 价格”输出查询结果,其中价格保留两位小数。当用户连续查询次数超过5次、或主动输入0时,程序结束。

输入样例1:

3 -1 0 2

输出样例1:

[1] apple
[2] pear
[3] orange
[4] grape
[0] exit
price = 4.10
price = 0.00

输入样例2:

1 2 3 3 4 4 5 6 7 8

输出样例2:

[1] apple
[2] pear
[3] orange
[4] grape
[0] exit
price = 3.00
price = 2.50
price = 4.10
price = 4.10
price = 10.20

以下是使用 switch case 的 C++ 代码实现:

#include <stdio.h>

int main()
{
    // 水果单价
    double price[4] = {3.00, 2.50, 4.10, 10.20};

    // 显示菜单
    printf("[1] apple\n[2] pear\n[3] orange\n[4] grape\n[0] exit\n");

    int count = 0; // 连续查询次数
    int input; // 用户输入的编号
    while (scanf("%d", &input) == 1 && input != 0 && count < 5) {
        switch (input) {
            case 1: // 苹果
                printf("price = %.2lf\n", price[0]);
                break;
            case 2: // 梨
                printf("price = %.2lf\n", price[1]);
                break;
            case 3: // 桔子
                printf("price = %.2lf\n", price[2]);
                break;
            case 4: // 葡萄
                printf("price = %.2lf\n", price[3]);
                break;
            default: // 其他编号
                printf("price = 0.00\n");
                break;
        }
        count++; // 连续查询次数加1
    }

    return 0;
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值