poj 2109

题目

Description

Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be only of theoretical interest.
This problem involves the efficient computation of integer roots of numbers.
Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the n th. power, for an integer k (this integer is what your program must find).

Input

The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10 101 and there exists an integer k, 1<=k<=10 9 such that k n = p.

Output

For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p.

Sample Input

2 16
3 27
7 4357186184021382204544

Sample Output

4
3
1234
其实就是求k的n次方等于p,给出n和p,求k
第一种办法很简单...具体原理我没怎么看懂= =   转载如下
int main(void)
{
    double n, p;
    while (2 == scanf("%lf%lf", &n, &p))
    {
        printf("%.0f\n", pow(p, 1/n));
    }

    return 0;
}
   
   

这题其实最大漏洞就在于k的范围被限制在了1<=k<=10^9内。

double的有效数字是15~16位,也就是说将p塞进double误差率在10^-15数量级左右。而开n次根号误差率是只会减小不会增大的,塞回double误差率仍然是10^-15左右的数量级。而答案只可能有9位有效数字,显然这个误差率只会影响到小数部分而不会对整数部分有影响,四舍五入之后就能得到结果。

如果这题没有限定整数k的范围,那这个解答显然就不能通过,只要p很大而n很小就无法得到正确结果。
作者:Gomo Psivarh 链接:https://www.zhihu.com/question/36462361/answer/67581595 来源:知乎
第二种办法就是在0到无穷的(很大很大)的整数范围内二分查找
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
double p;
int n;
void solve(){
    long long right,left,mid;
    double tmp;
    left=0;
    right=1000000002;
    while(left<=right){
        mid=(left+right)/2;
        tmp=pow(mid,n);
        if(tmp==p){
            printf("%lld\n",mid);
            return ;
        }
        else
            if(tmp>p)
                right=mid;
            else
                left=mid+1;
    }
    return ;
}

int main(){

    while(scanf("%d%lf",&n,&p)!=EOF)
    solve();
    return 0;
}

由于p很大,需要用double存储,今天我才知道double并不是只能表示16位的数
类型          长度 (bit)           有效数字          绝对值范围
float             32                      6~7                  10^(-37) ~ 10^38
double          64                     15~16               10^(-307) ~10^308
long double   128                   18~19                10^(-4931) ~ 10 ^ 4932
震惊不老铁...
这里有一个介绍float,double如何存储的网址,还不错
http://www.cnblogs.com/c-primer/p/5992696.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值