UVA - 210 Concurrency Simulator

UVA - 210 Concurrency Simulator

Programs executed concurrently on a uniprocessor system appear to be executed at the same time, but
in reality the single CPU alternates between the programs, executing some number of instructions from
each program before switching to the next. You are to simulate the concurrent execution of up to ten
programs on such a system and determine the output that they will produce.
The program that is currently being executed is said to be running, while all programs awaiting
execution are said to be ready. A program consists of a sequence of no more than 25 statements, one
per line, followed by an end statement. The statements available are listed below.
Statement Type Syntax
Assignment variable = constant
Output print variable
Begin Mutual Exclusion lock
End Mutual Exclusion unlock
Stop Execution end
A variable is any single lowercase alphabetic character and a constant is an unsigned decimal number less than 100. There are only 26 variables in
the computer system, and they are shared among
the programs. Thus assignments to a variable
in one program affect the value that might be
printed by a different program. All variables are
initially set to zero.
Each statement requires an integral number of time units to execute. The running program is
permitted to continue executing instructions for a period of time called its quantum. When a program’s
time quantum expires, another ready program will be selected to run. Any instruction currently being
executed when the time quantum expires will be allowed to complete.
Programs are queued first-in-first-out for execution in a ready queue. The initial order of the ready
queue corresponds to the original order of the programs in the input file. This order can change,
however, as a result of the execution of lock and unlock statements.
The lock and unlock statements are used whenever a program wishes to claim mutually exclusive
access to the variables it is manipulating. These statements always occur in pairs, bracketing one or
more other statements. A lock will always precede an unlock, and these statements will never be
nested. Once a program successfully executes a lock statement, no other program may successfully
execute a lock statement until the locking program runs and executes the corresponding unlock
statement. Should a running program attempt to execute a lock while one is already in effect, this
program will be placed at the end of the blocked queue. Programs blocked in this fashion lose any of their
current time quantum remaining. When an unlock is executed, any program at the head of the blocked
queue is moved to the head of the ready queue. The first statement this program will execute when
it runs will be the lock statement that previously failed. Note that it is up to the programs involved
to enforce the mutual exclusion protocol through correct usage of lock and unlock statements. (A
renegade program with no lock/unlock pair could alter any variables it wished, despite the proper use
of lock/unlock by the other programs.)
Input
The input begins with a single positive integer on a line by itself indicating the number of the cases
following, each of them as described below. This line is followed by a blank line, and there is also a
blank line between two consecutive inputs.
The first line of the input file consists of seven integers separated by spaces. These integers specify
(in order): the number of programs which follow, the unit execution times for each of the five statements
(in the order given above), and the number of time units comprising the time quantum. The remainder
of the input consists of the programs, which are correctly formed from statements according to the
rules described above.
All program statements begin in the first column of a line. Blanks appearing in a statement should
be ignored. Associated with each program is an identification number based upon its location in the
input data (the first program has ID = 1, the second has ID = 2, etc.).
Output
For each test case, the output must follow the description below. The outputs of two consecutive cases
will be separated by a blank line.
Your output will contain of the output generated by the print statements as they occur during the
simulation. When a print statement is executed, your program should display the program ID, a colon,
a space, and the value of the selected variable. Output from separate print statements should appear
on separate lines.
Sample Input
3 1 1 1 1 1 1
a = 4
print a
lock
b = 9
print b
unlock
print b
end
a = 3
print a
lock
b = 8
print b
unlock
print b
end
b = 5
a = 17
print a
print b
lock
b = 21
print b
unlock
print b
end
Sample Output
1: 3
2: 3
3: 17
3: 9
1: 9
1: 9
2: 8
2: 8
3: 21
3: 21

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cctype>
#include <queue>
using namespace std;
const int Maxn = 1005;
deque <int> readQ;
queue <int> blockQ;
int n,Q,c[5],var[26],ip[Maxn];
bool blocked;
char prog[Maxn][10];

void Run(int pid) {
    int q = Q;
    while(q) {
        char *p = prog[ip[pid]];
        switch(p[2]) {
            case '=':
                var[p[0] - 'a']  = isdigit(p[5]) ? (p[4] - '0') * 10 + (p[5] - '0') : p[4] - '0';
                q -= c[0];
                break;
            case 'i':
                printf("%d: %d\n", pid + 1, var[p[6] - 'a']);
                q -= c[1];
                break;
            case 'c':
                if(blocked) { blockQ.push(pid); return ; }
                blocked = true;
                q -= c[2];
                break;
            case 'l':
                blocked = false;
                if(!blockQ.empty()) {
                    readQ.push_front(blockQ.front());
                    blockQ.pop();
                }
                q -= c[3];
                break;
            case 'd' : return ;
        }
        ip[pid]++;
    }
    readQ.push_back(pid);
}

int main() {
    int T = 1;// scanf("%d",&T);
    while(T--) {
        scanf("%d",&n);
        for(int i=0; i<5; i++) scanf("%d",&c[i]);
        scanf("%d",&Q);
        memset(var,0,sizeof(var));
        int line = 0;
        for(int i=0; i<n; i++) {
            fgets(prog[line++],Maxn,stdin);
            ip[i] = line - 1;// ip  第几个程序执行到第几行
            while(prog[line - 1][2] != 'd')
                fgets(prog[line++],Maxn,stdin);
            readQ.push_back(i);// 第几个程序
        }
        //cout << " --- " << endl;
        blocked = false;
        while(!readQ.empty() ) {
            int pid = readQ.front(); readQ.pop_front();
            Run(pid);
        }
        if(T) printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

七情六欲·

学生党不容易~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值