实验3_类与对象的构造和应用

3-4 计算长方形的周长和面积

Time Limit: 1000MS Memory Limit: 65536KB
Submit Statistic
Problem Description

通过本题的练习可以掌握拷贝构造函数的定义和使用方法;
设计一个长方形类Rect,计算长方形的周长与面积。类中有私有数据成员Length(长)、Width(宽),由具有缺省参数值的构造函数对其初始化,函数原型为:Rect(double Length=0, double Width=0); 再为其定义拷贝构造函数,形参为对象的常引用,函数原型为:Rect(const Rect &); 编写主函数,创建Rect对象r1初始化为长、宽数据,利用r1初始化另一个Rect对象r2,分别输出对象的长和宽、周长和面积。

要求: 创建对象 Rect r1(3.0,2.0),r2(r1);
Input

输入两个实数,中间用一个空格间隔;代表长方形的长和宽
Output

共有6行 ;
分别输出r1的长和宽; r1的周长; r1的面积;r2的长和宽; r2的周长; r2的面积;注意单词与单词之间用一个空格间隔
Example Input

56 32
Example Output

the length and width of r1 is:56,32
the perimeter of r1 is:176
the area of r1 is:1792
the length and width of r2 is:56,32
the perimeter of r2 is:176
the area of r2 is:1792
Hint

输入 -7.0 -8.0
输出
the length and width of r1 is:0,0
the perimeter of r1 is:0
the area of r1 is:0
the length and width of r2 is:0,0
the perimeter of r2 is:0
the area of r2 is:0
Author

黄晶晶

code

#include <iostream>
#include <string>
using namespace std;

class rect
{
private:
    double len;
    double wid;
public:
    rect(double lenx, double widx)
    {
        len = lenx;
        wid = widx;
    }
    rect(const rect &r);
    void display(int i);
};

rect::rect(const rect &r)
{
    len = r.len;
    wid = r.wid;
}

void rect::display(int i)
{
    string s;
    if(i==0)
        s = "r1";
    else if(i==1)
        s = "r2";
    cout << "the length and width of "<< s << " is:" << len << "," << wid << endl;
    cout << "the perimeter of "<< s << " is:" << (len + wid)*2 <<endl;
    cout << "the area of "  << s << " is:" << len * wid << endl;
}


int main()
{
    double a, b;
    int i;
    cin >> a >> b;
    if(a<0 || b<0)
    {
        a=0;
        b=0;
    }
    rect r1(a,b);
    i = 0;
    r1.display(i);
    rect r2 = r1;
    i++;
    r2.display(i);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值