如何解决Apache服务配置问题

Coding 专栏收录该内容
13 篇文章 0 订阅

为了使得Apache2服务器能够为Python应用提供服务,也是绞尽了脑子。

首先在error.log中查看Apache现在启动的模块。

AH00163: Apache/2.4.18 (Ubuntu) mod_jk/1.2.41 mod_wsgi/4.3.0 Python/3.5.2 configured -- resuming normal operations

这个时候可以看到Python版本以及wsgi版本。

使用Apache的一个神器命令,Apache启动失败很大一部分是因为conf错误。通过检查configure可以直接定位错误信息。

这个命令就是

apache2ctl configtest

进入到/etc/apache2文件夹中,输入命令,可以定位到错误的配置信息。

比如Python版本、mod_python、以及libapache2-mod-wsgi-py3才是Python3的一个模块。

然后再通过错误信息,一步步解决问题。

  • 1
    点赞
  • 0
    评论
  • 0
    收藏
  • 打赏
    打赏
  • 扫一扫,分享海报

参与评论 您还未登录,请先 登录 后发表或查看评论
©️2022 CSDN 皮肤主题:大白 设计师:CSDN官方博客 返回首页

打赏作者

flowerlakey

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值