linux离线安装tensorflow_gpu

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/qq_36035264/article/details/86627200
  1. tensorflow_gpu-1.12.0 依赖库一览

下载网站:https://pypi.org/

Processing ./whl/tensorflow_gpu-1.12.0-cp27-cp27mu-manylinux1_x86_64.whl
Requirement already satisfied: keras-preprocessing>=1.0.5 in ./anaconda2/lib/python2.7/site-packages (from tensorflow-gpu==1.12.0)
Requirement already satisfied: enum34>=1.1.6 in ./anaconda2/lib/python2.7/site-packages (from tensorflow-gpu==1.12.0)
Requirement already satisfied: astor>=0.6.0 in ./anaconda2/lib/python2.7/site-packages (from tensorflow-gpu==1.12.0)
Requirement already satisfied: backports.weakref>=1.0rc1 in ./anaconda2/lib/python2.7/site-packages (from tensorflow-gpu==1.12.0)
Requirement already satisfied: wheel in ./anaconda2/lib/python2.7/site-packages (from tensorflow-gpu==1.12.0)
Requirement already satisfied: mock>=2.0.0 in ./anaconda2/lib/python2.7/site-packages (from tensorflow-gpu==1.12.0)
Requirement already satisfied: tensorboard<1.13.0,>=1.12.0 in ./anaconda2/lib/python2.7/site-packages (from tensorflow-gpu==1.12.0)
Requirement already satisfied: gast>=0.2.0 in ./anaconda2/lib/python2.7/site-packages/gast-0.2.2-py2.7.egg (from tensorflow-gpu==1.12.0)
Requirement already satisfied: termcolor>=1.1.0 in ./anaconda2/lib/python2.7/site-packages (from tensorflow-gpu==1.12.0)
Requirement already satisfied: protobuf>=3.6.1 in ./anaconda2/lib/python2.7/site-packages (from tensorflow-gpu==1.12.0)
Requirement already satisfied: absl-py>=0.1.6 in ./anaconda2/lib/python2.7/site-packages/absl_py-0.7.0-py2.7.egg (from tensorflow-gpu==1.12.0)
Requirement already satisfied: six>=1.10.0 in ./anaconda2/lib/python2.7/site-packages (from tensorflow-gpu==1.12.0)
Requirement already satisfied: keras-applications>=1.0.6 in ./anaconda2/lib/python2.7/site-packages (from tensorflow-gpu==1.12.0)
Requirement already satisfied: grpcio>=1.8.6 in ./anaconda2/lib/python2.7/site-packages (from tensorflow-gpu==1.12.0)
Requirement already satisfied: numpy>=1.13.3 in ./anaconda2/lib/python2.7/site-packages (from tensorflow-gpu==1.12.0)
Requirement already satisfied: funcsigs>=1; python_version < "3.3" in ./anaconda2/lib/python2.7/site-packages (from mock>=2.0.0->tensorflow-gpu==1.12.0)
Requirement already satisfied: pbr>=0.11 in ./anaconda2/lib/python2.7/site-packages (from mock>=2.0.0->tensorflow-gpu==1.12.0)
Requirement already satisfied: futures>=3.1.1; python_version < "3" in ./anaconda2/lib/python2.7/site-packages (from tensorboard<1.13.0,>=1.12.0->tensorflow-gpu==1.12.0)
Requirement already satisfied: markdown>=2.6.8 in ./anaconda2/lib/python2.7/site-packages (from tensorboard<1.13.0,>=1.12.0->tensorflow-gpu==1.12.0)
Requirement already satisfied: werkzeug>=0.11.10 in ./anaconda2/lib/python2.7/site-packages (from tensorboard<1.13.0,>=1.12.0->tensorflow-gpu==1.12.0)
Requirement already satisfied: setuptools in ./anaconda2/lib/python2.7/site-packages (from protobuf>=3.6.1->tensorflow-gpu==1.12.0)
Requirement already satisfied: h5py in ./anaconda2/lib/python2.7/site-packages (from keras-applications>=1.0.6->tensorflow-gpu==1.12.0)

注:

  • .whl文件直接使用pip安装
pip isntall XXX.whl
  • .tar.gz文件解压到anaconda2/lib/python2.7/site-packages/,进入文件夹安装
python setup.py install
  1. 安装tensorflow_gpu
pip install tensorflow_gpu-1.12.0-cp27-cp27mu-manylinux1_x86_64.whl
展开阅读全文

没有更多推荐了,返回首页