AVL

1123. Is It a Complete AVL Tree (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

    

    

Now given a sequence of insertions, you are supposed to output the level-order traversal sequence of the resulting AVL tree, and to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<= 20). Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, insert the keys one by one into an initially empty AVL tree. Then first print in a line the level-order traversal sequence of the resulting AVL tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line. Then in the next line, print "YES" if the tree is complete, or "NO" if not.

Sample Input 1:
5
88 70 61 63 65
Sample Output 1:
70 63 88 61 65
YES
Sample Input 2:
8
88 70 61 96 120 90 65 68
Sample Output 2:
88 65 96 61 70 90 120 68
NO
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<string>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<vector>
#include<list>
#include<queue>
#include<bitset>
#include<complex>
#include<deque>
#include<climits>
#include<cassert>
#include<stack>
#include<set>
#include<map>
#include<utility>
#include<cctype>
#include<sstream>
#include<iomanip>
#include<numeric>
using namespace std;
#define cl(a,b) memset(a,b,sizeof(a))
#define ll long long
#define INF 0x3f3f3f3f
struct node{
    int key,height;
    node *l,*r;
};
int geth(node *root)
{
    if(root)return root->height;
    else return -1;
}
node *LL(node *root)
{
    node *a,*b,*c;
    a=root;
    b=root->l;
    c=b->l;
    a->l=b->r;
    b->r=a;
    if(a)a->height=max(geth(a->l),geth(a->r))+1;
    if(c)c->height=max(geth(c->l),geth(c->r))+1;
    return b;
}
node *RR(node *root)
{
    node *a,*b,*c;
    a=root;
    b=root->r;
    c=b->r;
    a->r=b->l;
    b->l=a;
    if(a)a->height=max(geth(a->l),geth(a->r))+1;
    if(c)c->height=max(geth(c->l),geth(c->r))+1;
    return b;
}
node *LR(node *root){
    root->l=RR(root->l);
    return LL(root);
}
node *RL(node *root)
{
    root->r=LL(root->r);
    return RR(root);
}
node *Insert(node *root,int key)
{
    if(!root)
    {
        root=new node;
        root->key=key;
        root->height=0;
        root->l=root->r=NULL;
    }
    else
    {
        if(root->key>key)
            root->l=Insert(root->l,key);
        else root->r=Insert(root->r,key);
        int h1,h2;
        h1=geth(root->l);
        h2=geth(root->r);
        if(h1>h2+1)
        {
            int h3,h4;
            h3=geth(root->l->l);
            h4=geth(root->l->r);
            if(h3>h4)root=LL(root);
            else root=LR(root);
        }
        else if(h2>h1+1)
        {
            int h3,h4;
            h3=geth(root->r->l);
            h4=geth(root->r->r);
            if(h3>h4)root=RL(root);
            else root=RR(root);
        }
        root->height=max(geth(root->l),geth(root->r))+1;
    }
    return root;
}
bool level(node *root)
{
    queue<node*>q;
    q.push(root);
    bool flag=false,leave=false;
    printf("%d",root->key);
    while(!q.empty())
    {
        node *tmp=q.front();
        q.pop();
        if(tmp->l)
        {
            printf(" %d",tmp->l->key);
            q.push(tmp->l);
        }
        if(tmp->r)
        {
            printf(" %d",tmp->r->key);
            q.push(tmp->r);
        }
        if(!tmp->l&&tmp->r)flag=true;
        if(leave&&(tmp->r||tmp->l))flag=true;
        if(!tmp->r||!tmp->l){
            leave=true;
        }
    }
    printf("\n");
    return flag;
}
int main()
{

    int n,tmp;
    node *root=NULL;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        scanf("%d",&tmp);
        root=Insert(root,tmp);
    }
    bool cmp;
    cmp=level(root);
    if(!cmp)puts("YES");
    else puts("NO");
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值