hdu1325 并查集-好题

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.



In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
Output
For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
Sample Input
6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1
Sample Output
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

思路:(参考大神博客,方向性注意)不能成环,不能成树林,任何一个节点的入度不能大于1;

ps:入度:有多少条边指向这个点,出度就是从这个点出发有多少条边;

#include<stdio.h>
int pre[100020],flag[100020];
int find(int x)//不能路径压缩,递归找根结点; 
{	
	if(pre[x]==x)
		return x;
	else
		return find(pre[x]);
}
int main()
{
	int m,n,i,k,p=1;
	while(scanf("%d %d",&m,&n)!=EOF)
	{
		if(m<0&&n<0)
			break;
		int tot=0,ans=0;
		if(m+n==0)//m=0,n=0时条件; 
		{
			printf("Case %d is a tree.\n",p++);
			continue;
		}
		for(i=1;i<=100010;i++)
		{
			pre[i]=i;
			flag[i]=0;
		} 
		flag[n]=flag[m]=1;//标记m,n出现过; 
		pre[n]=m;
		//这道题和前篇博客hdu小希的迷宫类似,但这道题有方向性,详看第一幅图的方向; 
		//由n指向m,而不能由m指向n,这样查找父亲结点时就能查出入度大于1的节点了;
		//可以让m,n颠倒位置看看测试 1 2 3 2 0 0,这组数据is not a tree; 
		while(scanf("%d %d",&m,&n) && (m+n))
		{
			flag[m]=flag[n]=1; 
			int fx=find(m);
			int fy=find(n);
			if(fx!=fy)
				pre[n]=m;//同上; 
			else ans=1;
		}
		if(ans)//有环; 
		{
			printf("Case %d is not a tree.\n",p++);
			continue;
		}
		for(i=1;i<=100010;i++)
		{
			if(flag[i] && pre[i]==i)
				tot++;
			if(tot>1) break;
		}
		if(tot>1)//入度大于1了或者成树林了; 
			printf("Case %d is not a tree.\n",p++);
		else printf("Case %d is a tree.\n",p++);
	}
	return 0;
}

  • 1
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 7
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 7
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值