hdu 2602 01背包

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 56935    Accepted Submission(s): 23782


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
      
      
1
5 10
1 2 3 4 5
5 4 3 2 1
 

Sample Output
      
      
14
 

动态规划先找出子问题,我们可以这样考虑:在物品比较少,背包容量比较小时怎么解决?用一个数组f[i][j]表示,在只有i个物品,容量为j的情况下背包问题的最优解,那么当物品种类变大为i+1时,最优解是什么?第i+1个物品可以选择放进背包或者不放进背包,假设放进背包(前提是放得下),那么f[i+1][j]=f[i][j-weight[i+1]+value[i+1];如果不放进背包,那么f[i+1][j]=f[i][j]。放不下就是f[i+1][j]=f[i][j];

这就得出了状态转移方程:

f[i+1][j]=max(f[i][j],f[i][j-weight[i+1]+value[i+1])

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
int f[1010][1010],weight[1010],value[1010];
int main()
{
	int t,n,m,i,j;
	scanf("%d",&t);
	while(t--) 
	{
		scanf("%d %d",&n,&m);
		for(i=1;i<=n;i++)
			scanf("%d",&value[i]);
		for(i=1;i<=n;i++)
			scanf("%d",&weight[i]);
		for(i=1;i<=n;i++)
		{
			for(j=0;j<=m;j++)//骨头的占用空间可能为0; 
			{
				if(weight[i]<=j)
					f[i][j]=max(f[i-1][j],f[i-1][j-weight[i]]+value[i]);
				else f[i][j]=f[i-1][j];
			}
		}
		printf("%d\n",f[n][m]);
	}
	return 0;
}
上面计算f[i][j]可以看出,在计算f[i][j]时只使用了f[i-1][0……j],没有使用其他子问题,因此在存储子问题的解时,只存储f[i-1]子问题的解即可。这样可以用两个一维数组解决,一个存储子问题,一个存储正在解决的子问题。 再进一步思考,计算 f[i][j]时只使用了f[i-1][0……j],没有使用f[i-1][j+1]这样的话,我们先计算j的循环时,让j=M……1,只使用一个一维数组即可。 这就得出了状态转移方程:

f[j]=max(f[j],f[j-weight[i]+value[i]) ;

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int f[1010],weight[1010],value[1010];//全局变量,自动清0; 
int main()
{
	int t,n,m,i,j;
	scanf("%d",&t);
	while(t--) 
	{
		memset(f,0,sizeof(f));//记得清0; 
		scanf("%d %d",&n,&m);
		for(i=1;i<=n;i++)
			scanf("%d",&value[i]);
		for(i=1;i<=n;i++)
			scanf("%d",&weight[i]);
		for(i=1;i<=n;i++)
		{
			for(j=m;j>=weight[i];j--)
			{
				f[j]=max(f[j],f[j-weight[i]]+value[i]);
			}
		}
		printf("%d\n",f[m]);
	}
	return 0;
} 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值