poj2251 Dungeon Master

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?
Input
The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.
Output
Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!
Sample Input
3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0
Sample Output
Escaped in 11 minute(s).
Trapped!

思路:(六个方向写的有点冗长)这是一个三维的迷宫问题,按照二维的思路即可,注意三维数组的输入方式(不同于现实数学);

#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
int L,R,C;
char map[40][40][40];
struct node
{
	int x;
	int y;
	int z;
	int step;
	bool friend operator<(node a,node b)
	{
		return a.step>b.step;
	}
};
void bfs(int startx,int starty,int startz,int endx,int endy,int endz)
{
	bool flag=false;
	priority_queue<node> q;
	node now,next;
	now.x=startx;
	now.y=starty;
	now.z=startz;
	now.step=0;
	q.push(now);
	while(!q.empty())
	{
		next=q.top();
		q.pop();
		if(next.x==endx && next.y==endy && next.z==endz)
		{
			flag=true;
			break;
		}
		for(int i=0;i<6;i++)
		{
			if(i==0)
			{
				now.x=next.x+0;
				now.y=next.y+1;
				now.z=next.z;
			}
			if(i==1)
			{
				now.x=next.x-1;
				now.y=next.y+0;
				now.z=next.z;
			}
			if(i==2)
			{
				now.x=next.x+0;
				now.y=next.y-1;
				now.z=next.z;
			}
			if(i==3)
			{
				now.x=next.x+1;
				now.y=next.y+0;
				now.z=next.z;
			}
			if(i==4)
			{
				now.x=next.x;
				now.y=next.y;
				now.z=next.z+1;
			}
			if(i==5)
			{
				now.x=next.x;
				now.y=next.y;
				now.z=next.z-1;
			}
			if(map[now.x][now.y][now.z]!='#' && 1<=now.x && now.x<=R && 1<=now.y && now.y<=C && 1<=now.z && now.z<=L)
			{
				map[now.x][now.y][now.z]='#';
				now.step=next.step+1;
				q.push(now);
			}
		}
	}
	if(flag) printf("Escaped in %d minute(s).\n",next.step);
	else printf("Trapped!\n");
}
int main()
{
	int x1,x2,y1,y2,z1,z2;
	while(scanf("%d %d %d",&L,&R,&C) && (L+R+C))
	{
		memset(map,0,sizeof(map));
		for(int i=1;i<=L;i++)
		{
			if(i>1)//注意点
				getchar();
			for(int j=1;j<=R;j++)
			{
				getchar();
				for(int p=1;p<=C;p++)
				{
					scanf("%c",&map[j][p][i]);//注意点,并不是map[i][j][p];
					if(map[j][p][i]=='S')
					{
						z1=i;
						x1=j;
						y1=p;

					}
					if(map[j][p][i]=='E')
					{
						z2=i;
						x2=j;
						y2=p;
					}
				}
			}
		}
		bfs(x1,y1,z1,x2,y2,z2);
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值