CodeForces 586B

B -B
Time Limit: 1000MS     Memory Limit: 262144KB      64bit IO Format: %I64d & %I64u

Description

A little boy Laurenty has been playing his favourite game Nota for quite a while and is now very hungry. The boy wants to make sausage and cheese sandwiches, but first, he needs to buy a sausage and some cheese.

The town where Laurenty lives in is not large. The houses in it are located in two rows,n houses in each row. Laurenty lives in the very last house of the second row. The only shop in town is placed in the first house of the first row.

The first and second rows are separated with the main avenue of the city. The adjacent houses of one row are separated by streets.

Each crosswalk of a street or an avenue has some traffic lights. In order to cross the street, you need to press a button on the traffic light, wait for a while for the green light and cross the street. Different traffic lights can have different waiting time.

The traffic light on the crosswalk from the j-th house of thei-th row to the (j + 1)-th house of the same row has waiting time equal toaij (1 ≤ i ≤ 2, 1 ≤ j ≤ n - 1). For the traffic light on the crossing from thej-th house of one row to the j-th house of another row the waiting time equals bj (1 ≤ j ≤ n). The city doesn't have any other crossings.

The boy wants to get to the store, buy the products and go back. The main avenue of the city is wide enough, so the boy wants to cross itexactly once on the way to the store and exactly once on the way back home. The boy would get bored if he had to walk the same way again, so he wants the way home to be different from the way to the store in at least one crossing.

Figure to the first sample.

Help Laurenty determine the minimum total time he needs to wait at the crossroads.

Input

The first line of the input contains integer n (2 ≤ n ≤ 50) — the number of houses in each row.

Each of the next two lines contains n - 1 space-separated integer — valuesaij (1 ≤ aij ≤ 100).

The last line contains n space-separated integersbj (1 ≤ bj ≤ 100).

Output

Print a single integer — the least total time Laurenty needs to wait at the crossroads, given that he crosses the avenue only once both on his way to the store and on his way back home.

Sample Input

Input
4
1 2 3
3 2 1
3 2 2 3
Output
12
Input
3
1 2
3 3
2 1 3
Output
11
Input
2
1
1
1 1
Output
4

Sample Output

Hint

The first sample is shown on the figure above.

In the second sample, Laurenty's path can look as follows:

  • Laurenty crosses the avenue, the waiting time is 3;
  • Laurenty uses the second crossing in the first row, the waiting time is 2;
  • Laurenty uses the first crossing in the first row, the waiting time is 1;
  • Laurenty uses the first crossing in the first row, the waiting time is 1;
  • Laurenty crosses the avenue, the waiting time is 1;
  • Laurenty uses the second crossing in the second row, the waiting time is 3.
In total we get that the answer equals  11.

In the last sample Laurenty visits all the crossings, so the answer is 4.

题意:一个大道,两旁居民楼,居民楼之间和大道之间都有红灯,问最短时间;

思路:如果你没有学最短路(前提你是蒟蒻),那么这道题是水题,或者也是简单的最短路问题,可是dij模拟了好久,就是不对,看来本就蒟蒻;

ps:这道题之所以最后写,应为时间过了我的dij还是不对,最后问了百度,枚举就可以解决,但是代码绝对原创,泪奔我可能学了假的最短路;

街道概况:

1  2  3... n (大道一侧)

。。。。。(两侧 1-1,2-2,3-3...n-n 的权值)

1  2  3....n(大道另一侧)

按题目模拟啊,弄什么最短路啊,,把所有的情况写出来,然后sort;

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f
int a[1010],b[1010],c[1010],s[10010];
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		memset(c,0,sizeof(c));
		memset(s,0,sizeof(s));
		for(int i=1;i<=n-1;i++)
			scanf("%d",&a[i]);
		for(int i=1;i<=n-1;i++)
			scanf("%d",&b[i]);
		for(int i=1;i<=n;i++)
			scanf("%d",&c[i]);
		for(int i=1;i<=n;i++)
		{
			int k=0;
			for(int j=1;j<=i;j++)
			{
				k+=a[j-1];
			}
			k+=c[i];
			for(int j=i;j<=n-1;j++)
			{
				k+=b[j];
			}
			s[i-1]=k;
		}
		sort(s,s+n);
		printf("%d\n",s[0]+s[1]);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值