zoj Modular Inverse

The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1x (mod m). This is equivalent to ax≡1 (mod m).

Input

There are multiple test cases. The first line of input is an integer T ≈ 2000 indicating the number of test cases.

Each test case contains two integers 0 < a ≤ 1000 and 0 < m ≤ 1000.

Output

For each test case, output the smallest positive x. If such x doesn't exist, output "Not Exist".

Sample Input
3
3 11
4 12
5 13
Sample Output
4
Not Exist

思路:逆元裸题,题意中 c=1

#include<cstdio>
#include<cstring>
typedef long long LL;

LL exgcd(LL a,LL b,LL &x,LL &y){
	if(!b){
		x=1;
		y=0;
		return a;
	}
	LL ans=exgcd(b,a%b,x,y);
	LL t=x;
	x=y;
	y=t-a/b*y;
	return ans; 
} 

LL cal(LL a,LL b,LL c){
	LL x,y;
	LL gcd=exgcd(a,b,x,y);
	if(c%gcd!=0) return -1;
	x*=c/gcd;
	b/=gcd;
	if(b<0) b=-b;
	LL ans=x%b;
	if(ans<=0) ans+=b;
	return ans;
}
int main(){
	LL t,a,m;
	scanf("%lld",&t);
	while(t--){
		scanf("%lld%lld",&a,&m);
		LL ans=cal(a,m,1);
		if(ans==-1) printf("Not Exist\n");
		else printf("%lld\n",ans);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值