hdu4704 费马小定理+快速幂

Problem Description
 

Sample Input
  
  
2
 

Sample Output
  
  
2
Hint
1. For N = 2, S(1) = S(2) = 1. 2. The input file consists of multiple test cases.
思路:写下规律,就是求2^(n-1)%mod,但是n比较大,必须要降幂,就想到费马小定理:   p 是质数 , (a,p)=1, 那么 a^(p-1) ≡1 mod p

推导:2^n%m == ( 2^(n%(m-1))*2^(n/(m-1)*(m-1)) )%m==(2^(n%(m-1)))%m; 

#include<cstdio>
#include<cstring>
#define max_n 1000010
#define mod 1000000007
typedef long long ll;

char str[max_n];

ll quickpow(ll a,ll b,ll c)
{
	ll ans=1;
	while(b)
	{
		if(b&1)
			ans=ans*a%c;
		a=a*a%c;
		b>>=1;
	}
	return ans;
}

int main()
{
	while(~scanf("%s",str))
	{
		ll len=strlen(str);
		ll ans=0;
		for(ll i=0;i<len;i++)
			ans=(ans*10+str[i]-'0')%(mod-1);
		ans=(ans-1+mod-1)%(mod-1); 
		printf("%lld\n",quickpow(2,ans,mod));
	}
	return 0;
} 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值