hdu 2647【反向拓扑+前向星】

Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9199    Accepted Submission(s): 2937


Problem Description
Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.
 

Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.
 

Output
For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.
 

Sample Input
  
  
2 1 1 2 2 2 1 2 2 1
 

Sample Output
  
  
1777 -1  


思路:(这个拓扑关系,并查集应该解决不了)n,m比较大,利用邻接表去写;反向拓扑,用队列模拟广搜,一步步删边,更新入度;

#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<stack>
#include<queue>
#define max_n 20010 
using namespace std;
typedef long long LL;
int head[max_n],out[max_n],in[max_n];
int n,m,x,y;

struct node
{
	int to;
	int next;
}edge[max_n];

void toposort()
{
	int ans=0,sum=0;
	queue<int> q; //利用栈建立邻接表,运用bfs思想广搜; 
	for(int i=1;i<=n;i++)
	{
		if(in[i]==0)
		{
			in[i]--;
			out[i]=888; //有点dp式的意思,初始一下 
			q.push(i);
		}
	}
	while(!q.empty())
	{
		int node=q.front();
		q.pop();
		ans++; 
		for(int i=head[node];i!=-1;i=edge[i].next) //找出所有与当前点连接的所有点,拆去这个边,入度减一 
		{
	//		printf("%d->%d ",edge[i].to,i);
			in[edge[i].to]--;
			if(in[edge[i].to]==0)
			{
				in[edge[i].to]--;
				out[edge[i].to]=out[node]+1;
				q.push(edge[i].to);   //压入新的入度为0边 
			}
		}
		printf("\n");
	}
	if(ans!=n) printf("-1\n");
	else
	{
		for(int i=1;i<=n;i++)
			sum+=out[i];
		printf("%d\n",sum);
	}
}

int main()
{
	while(scanf("%d %d",&n,&m)!=EOF)
	{
		memset(head,-1,sizeof(head));
		memset(in,0,sizeof(in));
		memset(out,0,sizeof(out));
		for(int i=0;i<m;i++) //反向建立topo图 
		{
			scanf("%d %d",&x,&y);
			edge[i].to=x;
			edge[i].next=head[y];
			head[y]=i;
			in[x]++;
		}
		toposort();
	}
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值