POJ 3468 【线段树区间更新】

You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.
Input
The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.
Output
You need to answer all Q commands in order. One answer in a line.
Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output
4
55
9
15
Hint
The sums may exceed the range of 32-bit integers.

题意:
Q是查询区间和,C是使区间内的每个元素加上c;
分析:
线段树区间更新,最后区间求和就行,模板。

#include <cstdio> 
#include <algorithm>
#include <cstring>
#include <cmath>
using namespace std;

typedef long long LL;
const int mod = 24 * 60;
const int MAXN = 1e5 + 10;
LL dp[MAXN << 2], add[MAXN << 2];

void pushup(int root) {
    dp[root] = dp[root << 1] + dp[root << 1 | 1];
}

void pudown(int root, int L, int R) {
    if(add[root]) {//lazy具体步骤,之后会总体详解
        add[root << 1] += add[root];
        add[root << 1 | 1] += add[root];
        dp[root << 1] += add[root] * L;
        dp[root << 1 | 1] += add[root] * R;
        add[root] = 0;
    }
}

void build(int root, int L, int R) {
    if(L == R) {
        scanf("%lld", &dp[root]);
        return ;
    }
    int mid = (L + R) >> 1;
    build(root << 1, L, mid);
    build(root << 1 | 1, mid + 1, R);
    pushup(root);
}

void updata(int root, int L, int R, int l, int r, int c) {
    if(L >= l && R <= r) {
        dp[root] += c * (R - L + 1);//区间更新
        add[root] += c;
        return ;
    }
    int mid = (L + R) >> 1;
    pudown(root, mid - L + 1, R - mid);//lazy操作
    if(l <= mid) updata(root << 1, L, mid, l, r, c);
    if(r > mid) updata(root << 1 | 1, mid + 1, R, l, r, c);
    pushup(root);
}

LL query(int root, int L, int R, int l, int r) {
    if(L >= l && R <= r) {
        return dp[root];
    }
    LL ans = 0;
    int mid = (L + R) >> 1;
    pudown(root, mid - L + 1, R - mid);//lazy操作
    if(l <= mid) ans += query(root << 1, L, mid, l, r);
    if(r > mid) ans += query(root << 1 | 1, mid + 1, R, l, r);
    return ans;
}

int main() {
    int n, m;
    scanf("%d%d", &n, &m);
    build(1, 1, n);
    while(m--) {
        getchar();
        char ch;
        int x, y, c;
        scanf("%c", &ch);
        if(ch == 'Q') {
            scanf("%d %d", &x, &y);
            printf("%lld\n", query(1, 1, n, x, y));
        }
        else {
            scanf("%d %d %d", &x, &y, &c);
            updata(1, 1, n, x, y, c);//区间修改
        }
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值