POJ 1651 Multiplication Puzzle【区间DP】

题目: POJ 1651
The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.
The goal is to take cards in such order as to minimize the total number of scored points.
For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000
If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.
Input
The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.
Output
Output must contain a single integer - the minimal score.
Sample Input
6
10 1 50 50 20 5
Sample Output
3650

题意:
一个n个元素的序列,每次取一个元素a[i],代价为a[i] * a[i - 1] * a[i +1],取完之后形成新序列,继续重复操作,直到取出n-2个元素,求最小代价。
分析:
再一次逆序考虑,往第一个元素和最后一个元素之间插值,插入次序就是取出的逆顺序。枚举区间长度和起点,把区间内的每一个元素都当作最后一个元素,去取最小值(区间元素每次加一,每次都枚举区间内元素当作最后元素,新区间有序),只有最后取出的元素才能和两个区间临界值相乘。
dp[i][j](i,j); d p [ i ] [ j ] : ( i , j ) 区 间 最 小 代 价 ;
dp[i][j]=min(dp[i][j],dp[i][k]+dp[k][j]+a[i]a[k]a[j]); d p [ i ] [ j ] = m i n ( d p [ i ] [ j ] , d p [ i ] [ k ] + d p [ k ] [ j ] + a [ i ] ∗ a [ k ] ∗ a [ j ] ) ;

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
using namespace std;
typedef long long LL;

const int INF = 0x3f3f3f3f;
const int MAXN = 2e3 + 10;
int a[MAXN], dp[MAXN][MAXN];

int main() {
    int n;
    scanf("%d", &n);
    for(int i = 0; i <= n - 1; ++i) {
        scanf("%d", &a[i]);
    }
    for(int i = 1; i <= n - 2; ++i) { //初始化
        dp[i - 1][i + 1] = a[i - 1] * a[i] * a[i + 1];
    }
    for(int L = 3; L <= n; ++L) {
        for(int i = 0; i <= n - L - 1; ++i) {
            int j = L + i;
            dp[i][j] = INF;
            for(int k = i + 1; k < j; ++k) {
                dp[i][j] = min(dp[i][j], dp[i][k] + dp[k][j] + a[i] * a[k] * a[j]);
            }
        }
    }
    printf("%d\n", dp[0][n - 1]);
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值