POJ 2528 Mayor's posters( 线段树+离散化)

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:
  • Every candidate can place exactly one poster on the wall.
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
  • The wall is divided into segments and the width of each segment is one byte.
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall.
Input
The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.
Output
For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input.
Sample Input
1
5
1 4
2 6
8 10
3 4
7 10
Sample Output
离散化的思想:
对于这样的数据
(3,10000),
(9,1000000),
(5,100000),
(1,1000),
(7,1000000)
我们可以将其处理为
(2,7),
(5,9),
(3,8),
(1,6),
(4,9)

这样的话,就只需要9个数,而不是1000 000,大大的节省了空间和时间。

离散化简单的来说就是只取我们需要的值来用,比如说区间[1000,2000],[1990,2012] 我们用不到[-∞,999][1001,1989][1991,1999][2001,2011][2013,+∞]这些值,所以我只需要1000,1990,2000,2012就够了,将其分别映射到0,1,2,3,在于复杂度就大大的降下来了
所以离散化要保存所有需要用到的值,排序后,分别映射到1~n,这样复杂度就会小很多很多
而这题的难点在于每个数字其实表示的是一个单位长度(并非一个点),这样普通的离散化会造成许多错误(包括我以前的代码,poj这题数据奇弱)
给出下面两个简单的例子应该能体现普通离散化的缺陷:
例子一:1-10 1-4 5-10
例子二:1-10 1-4 6-10
普通离散化后都变成了[1,4][1,2][3,4]
线段2覆盖了[1,2],线段3覆盖了[3,4],那么线段1是否被完全覆盖掉了呢?
例子一是完全被覆盖掉了,而例子二没有被覆盖

为了解决这种缺陷,我们可以在排序后的数组上加些处理,比如说[1,2,6,10]如果相邻数字间距大于1的话,在其中加上任意一个数字,比如加成[1,2,3,6,7,10],然后再做线段树就好了.

还有就是这道题是从外面向里面,这样的话,我们先贴外面的,第一次,我们就把这个区间屏蔽,下次再来,就可以直接判断是不是外面有纸了。
#include <iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define INF 0x3f3f3f3f
#define lson(x) (x<<1)
#define rson(x) (x<<1|1)
#define ml(x,y) ((x+y)>>1)
using namespace std;
typedef long long ll;

const int maxn=1e4+10;
int l[maxn],r[maxn],s[maxn*4];
int Hash[10000010];
//不知道为什么必须开到点的个数的四倍,先记住吧。
//因为10000个区间,最多20000个点
struct node
{
    int l,r;
    int used;
}tree[maxn*16];

void build(int st,int ed,int nid)
{
    tree[nid].l=st;
    tree[nid].r=ed;
    tree[nid].used=0;
    if(st==ed)
        return;
    int mid=ml(st,ed);
    build(st,mid,lson(nid));
    build(mid+1,ed,rson(nid));
}

int update(int st,int ed,int nid)
{
    if(tree[nid].used)//说明該点的管辖范围已经全部都粘上了
        return 0;
    if(tree[nid].l==st&&tree[nid].r==ed)
    {
        tree[nid].used=1;//说明这段区间没有被用,那我们就标记
        return 1;
    }
    int mid=ml(tree[nid].l,tree[nid].r);
    int ans=0;//确实得设立一个ans
    if(ed<=mid)
        ans=update(st,ed,lson(nid));
    else if(st>mid)
        ans=update(st,ed,rson(nid));
    else
    {
        int ans1=update(st,mid,lson(nid));
        int ans2=update(mid+1,ed,rson(nid));
        ans=ans1||ans2;//只要有一个人能露出来就可以
    }
    tree[nid].used=tree[lson(nid)].used&&tree[rson(nid)].used;
    return ans;
}

int main()
{
  int T;
  scanf("%d",&T);
  while(T--)
  {
      memset(s,0,sizeof(s));
      memset(l,0,sizeof(l));
      memset(r,0,sizeof(r));
      int cnt=0;
      int n;
      scanf("%d",&n);
      for(int i=1;i<=n;i++)
      {
          scanf("%d %d",&l[i],&r[i]);
          s[cnt++]=l[i];
          s[cnt++]=r[i];
      }

      sort(s,s+cnt);
      cnt=unique(s,s+cnt)-s;//去重操作,就是把重复的数字去掉

      for (int i = cnt- 1 ; i > 0 ; i --) /*离散化技巧:凸显间隔(可避免上文的数据2出错)*/
      {
            if (s[i] != s[i-1] + 1) s[cnt ++] = s[i-1] + 1;//我们从末尾加上中间值,防止出错
      }
      sort(s,s+cnt);//再次排序

      for(int i=0;i<cnt;i++)//离散化处理数据
          Hash[s[i]]=i+1;
      build(1,cnt,1);//根据不同的节点数量创建树
      int ans=0;
      for(int i=n;i>0;i--)
      {
          if(update(Hash[l[i]],Hash[r[i]],1))//;给我解释一下,这个小分号是怎么自己上去的,细节啊
                 ans++;
      }
      printf("%d\n",ans);

  }
   return 0;
}


今天又写了一边,发现巨坑(有很多的小细节),一个是我想着用set,这样的话我们就不用去重了,发现没有办法添加,区别上面讲的,不过这道题的数据比较水,也过了。发现几个地方,
1.一个就是我们的压缩了,但是后面我们又添加了,所以说10000个点,L和R,两倍,又添加了中间的节点,所以四倍于maxn,所以我们的线段树直接就成了maxn*16
2.一开始想用map进行标记,发现TLE,原来二分也不能,。。。,只能随机存取,反正数也不是很大
3.update的时候自己总是忘记 往上的更新,只是找到就算了,没有利用好返回的一个路径,导致下面更新了,上面还没有更新

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<set>

using namespace std;
typedef long long LL;

const int maxn=10010;
int ll[maxn],rr[maxn];
int Hash[10000010];  
struct node{
	int l,r;
	int flag;
}tree[maxn*16]; 

void build(int st,int ed,int now){
	tree[now].l=st,tree[now].r=ed;
	tree[now].flag=0;
	if(st==ed)
		return;
	int mid=(st+ed)>>1;
	build(st,mid,now<<1);
	build(mid+1,ed,now<<1|1);
}
int update(int st,int ed,int now){
	if(tree[now].flag)
		return 0;
	if(tree[now].l==st&&tree[now].r==ed){

		return tree[now].flag=1;;
	}	
	int mid=(tree[now].l+tree[now].r)>>1;
	int ans;
	if(ed<=mid)
		ans=update(st,ed,now<<1);
	else if(st>mid)
		ans=update(st,ed,now<<1|1);
	else{
		int ans1=update(st,mid,now<<1);
		int ans2=update(mid+1,ed,now<<1|1);
		ans= ans1||ans2; 
	}
	tree[now].flag=tree[now<<1].flag&&tree[now<<1|1].flag;
	return ans;
}


int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		memset(ll,0,sizeof(ll));
		memset(rr,0,sizeof(rr));
		memset(Hash,0,sizeof(Hash)); 
		set<int> s;
		int n;
		scanf("%d",&n);
		for(int i=0;i<n;i++){
			scanf("%d %d",&ll[i],&rr[i]);
			if(!s.count(ll[i]))
				s.insert(ll[i]);
			if(!s.count(rr[i]))
				s.insert(rr[i]);
		}
		int cnt=0;
		for(set<int>::iterator it=s.begin();it!=s.end();it++){
			Hash[*it]=++cnt;//直接把所用的点全都缩小 
		}
		build(1,cnt,1);
		int ans=0;
		for(int i=n-1;i>=0;i--){
			if(update(Hash[ll[i]],Hash[rr[i]],1))
				ans++;
		}
		printf("%d\n",ans);
		
	}
	return 0;
} 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值