H - Hurdles of 110m ZOJ - 2972

In the year 2008, the 29th Olympic Games will be held in Beijing. This will signify the prosperity of China and Beijing Olympics is to be a festival for people all over the world as well.

Liu Xiang is one of the famous Olympic athletes in China. In 2002 Liu broke Renaldo Nehemiah's 24-year-old world junior record for the 110m hurdles. At the 2004 Athens Olympics Games, he won the gold medal in the end. Although he was not considered as a favorite for the gold, in the final, Liu's technique was nearly perfect as he barely touched the sixth hurdle and cleared all of the others cleanly. He powered to a victory of almost three meters. In doing so, he tied the 11-year-old world record of 12.91 seconds. Liu was the first Chinese man to win an Olympic gold medal in track and field. Only 21 years old at the time of his victory, Liu vowed to defend his title when the Olympics come to Beijing in 2008.

In the 110m hurdle competition, the track was divided into N parts by the hurdle. In each part, the player has to run in the same speed; otherwise he may hit the hurdle. In fact, there are 3 modes to choose in each part for an athlete -- Fast Mode, Normal Mode and Slow Mode. Fast Mode costs the player T1 time to pass the part. However, he cannot always use this mode in all parts, because he needs to consume F1 force at the same time. If he doesn't have enough force, he cannot run in the part at the Fast Mode. Normal Mode costs the player T2 time for the part. And at this mode, the player's force will remain unchanged. Slow Mode costs the player T3 time to pass the part. Meanwhile, the player will earn F2 force as compensation. The maximal force of a player is M. If he already has M force, he cannot earn any more force. At the beginning of the competition, the player has the maximal force.

The input of this problem is detail data for Liu Xiang. Your task is to help him to choose proper mode in each part to finish the competition in the shortest time.


Input

Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 50) which is the number of test cases. And it will be followed by T consecutive test cases.

Each test case begins with two positive integers N and M. And following N lines denote the data for the N parts. Each line has five positive integers T1 T2 T3 F1 F2. All the integers in this problem are less than or equal to 110.

Output

Results should be directed to standard output. The output of each test case should be a single integer in one line, which is the shortest time that Liu Xiang can finish the competition.

Sample Input
2
1 10
1 2 3 10 10
4 10
1 2 3 10 10
1 10 10 10 10
1 1 2 10 10
1 10 10 10 10

Sample Output
1
6

Hint

For the second sample test case, Liu Xiang should run with the sequence of Normal Mode, Fast Mode, Slow Mode and Fast Mode.


#include<cstdio>
#include<cstring>
#include<algorithm> 
#define bug(x) printf("%d***\n",x)
using namespace std;

const int INF=0x3f3f3f3f;
const int maxn=120;

int dp[maxn][maxn];
int f[maxn][3],val[maxn][2];
int n,m;


void print(){
	printf("*****\n");
	for(int i=1;i<=n;i++){
		for(int j=0;j<=m;j++){
			printf(" %d",dp[i][j]);
		}
		printf("\n");
	}
}
/*
多段图的最短路 
可能看汝佳的书可能感觉,哇,我明白了,
但是自己只是理解了一个点
一道真正的题,会有大量的点,和限制
自己不能拨开他的皮,看到里面的实质,还是做的少啊 
*/
int main(){
//	freopen("123.txt","w",stdout);
	int T;
	scanf("%d",&T);
	while(T--){
		memset(dp,INF,sizeof(dp));
		scanf("%d %d",&n,&m);
		for(int i=1;i<=n;i++){
			scanf("%d %d %d %d %d",&f[i][0],&f[i][1],&f[i][2],&val[i][0],&val[i][1]);
		}
		dp[0][m]=0;
		for(int i=1;i<=n;i++){
			for(int j=0;j<=m;j++){	
				dp[i][j]=min(dp[i][j],dp[i-1][j]+f[i][1]);
				if(j>=val[i][0])
					dp[i][j-val[i][0]]=min(dp[i][j-val[i][0]],dp[i-1][j]+f[i][0]);	
				int tmp=min(j+val[i][1],m);
				dp[i][tmp]=min(dp[i][tmp],dp[i-1][j]+f[i][2]);
				
			}
		} 
		int ans=INF;
		for(int i=0;i<=m;i++){
			ans=min(ans,dp[n][i]);
		}
		printf("%d\n",ans);
	}
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值