The sum problem

The sum problem

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 34679 Accepted Submission(s): 10362

Problem Description

Given a sequence 1,2,3,…N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.

Input

Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.

Output

For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.

Sample Input

20 10
50 30
0 0

Sample Output

[1,4]
[10,10]

[4,8]
[6,9]
[9,11]
[30,30]

题解

此题目不可暴力,会超时。需运用等差数列求和公式巧妙解题。

确定和 sum=m 的最长的长度,最长则从起点1开始。根据等差求和,公式为 :m = len(len+1)*; 根据放缩法则 len^2<2*m, 所以 len 最大等于 sqrt(2*m) ;现在根据长度确定起点 a, 根据等差求和公式,
a = ( m − ( i − 1 ) ∗ i / 2 ) / i = &gt; m = i ∗ a + i ∗ ( i − 1 ) / 2 a = (m - ( i - 1) * i / 2 ) / i =&gt; m = i * a + i * (i-1) / 2 a=(m(i1)i/2)/i=>m=ia+i(i1)/2
开始数字为 a, 结尾数字为 a+len-1;

代码:

#include<iostream>
#include<cmath>
using namespace std;

int main()
{
	int n, m;
	while(cin >> n >> m && n||m)
	{
		for(int i=sqrt(2*n); i>=1; i--)
		{
			int a = (m-(i-1)*i/2)/i;
			if(a==0) continue;
			if(m == i*a+i*(i-1)/2)
				cout << "[" << a << "," << a+i-1 << "]\n";
		}
		cout << endl;
	}
	return 0;
} 

参考博客 青山绿水之辈

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值